Texture is all black

Answered

Comments

7 comments

  • Avatar
    Wishgranter
    Hi Filipe

    Can post a screen ? its better then 100 worlds :D
    0
    Comment actions Permalink
  • Avatar
    Filipe Gonçalves
    I tried again and was able to get the texture. However the texture is strange and very low quality. Seems that most of the UV space is wasted and the parts that matter are distributed to many tiny islands. How can I fix this?
    Image

    The overall look of the scene:
    Image

    Inside 3ds max, after erasing the unwanted geometry:
    Image

    Notice how low quality texturing is.

    1 - How can I fix the strange geometry that is exported? The geometry seems to be coming from the distant points around the tree. How can I exlcude those points from mesh generation? I already chose a reconstruction region just around the tree but that has no effect.

    2 - How can I fix texturing and distribute the UV islands more evenly?

    Thank you
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Filipe

    1. best when set the BBox before reconstruction and set to more proper size. For now set BBox so it contains only waht need and use in RECONSTRUCTION ribbon the FILTERING tool and set all outside the Bbox and filter it out...

    2. what setting you used for the actual texturing ? can post screenshot ??
    and what UNWRAP parameters were used...
    0
    Comment actions Permalink
  • Avatar
    Filipe Gonçalves
    I have made a BBox around the tree only (just the trunk), but I can't use filtering because it's grey and I can't click it.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Filipe

    hope you used RECONSTRUCTION/SET RECONSTRUCTION REGION ( CTRL+SHIFT+U ) and changed its size and position
    0
    Comment actions Permalink
  • Avatar
    martinb
    Dear Filipe,

    thanks for posting this issue!

    Have you textured this scene before (in the old version) ? If it was so, it would reuse UVs from the previous scene. To regenerate UVs and textures with new algorithms -> go to RECONSTRUCTION tab and open UV tool. Define desired UV map properties and click Unwrap. It will regenerate UV. Then click TEXTURE to remake textures. Texture maps should be much better.
    0
    Comment actions Permalink
  • Avatar
    Michal | CR
    Dear Filipe,
    here: https://youtu.be/M6HXaPvcsbg
    you can see basic tutorial on User Interface. Please go 1Ds of the left panel where you will find a project tree. Expand it and select your model. A "selected model(s)" panel will appear. There you can see details about textures and model.

    You need to have a model selected in order to be able to use the filtering tool .

    When you will manage to filter the model ( a new filtered model will be created ) then you can use first the unwrap tool and export model to obj. Then open the model in an external app (the texture will be black) and check the generated UVs. If you like it then you can press texture button and it will create colors to the textures.

    Go to RECONSTRUCTION -> Settings -> Coloring/Texturing -> Texturing/Coloring style. Change it to "visibility based". This style is faster and produces good quality results.

    The settings RECONSTRUCTION -> Settings -> Coloring/Texturing -> Default unwrap parameters are used to unwrap the model JUST when the model is not unwrapped (has no texture no UVs). If the model has already UVs then when you press texturing then existin UVs will be used and just colors of texels will be computed.

    Thank you for the post : )
    0
    Comment actions Permalink

Please sign in to leave a comment.