Importing Model Error

Answered

Comments

4 comments

  • Avatar
    Wishgranter
    Hi Oscar Holm Hansen

    I have seen these errors in other software, like Lightwave. There is something not OK with the UVs ( in the OBJ file ) how they are stored, even though it looks OK. If you have Zbrush, try to import and export with it.

    Or send it to milos.lukac@capturingreality.com, so that I can take a look at it in some other software to see what is the precise issue.
    But in most cases UVs from Maya are working...
    0
    Comment actions Permalink
  • Avatar
    Ilja Burzev
    Hi Wishgranter,

    I have the same UV error problem when importing (some) new object. In all cases my UVs seems to be ok, no overlapping or out of UV area issues etc.

    For example this error appears if I import a cube (6 polys) created with cinema 4D. I did try to arrange the UVs both manually and with optimal mapping methode. I also tried to reexport the .obj with maya, zbrush and uvlayout (I tried a lot of cases as well as reworking UVs in the different programs) without any success. A lot of other objects exportet with cinema 4d like a sphere works well. I also was confused when I tried to export a cube with totally messed up UVs (like frontal or spherical UV projection - there is a lot of overlapping in the UV) and it did worked.

    Any idea why this behaviour happens?
    0
    Comment actions Permalink
  • Avatar
    Robert Moggach
    I've been dealing with alot of Z-Brush cleaned up scan data and hit this. Solution is rather abstract but this worked.

    1) Check your UVs in Maya. The "corrupted" UV shells for me showed one UV shell for each face despite having been built/projected from a properly UVd lowrez mesh. ie. lots of overlapping UVs

    2) Merge UVs in Maya DID NOT fix this for me.

    3) Open ZTool in Zbrush and select subtool in question.

    4) Select the Geometry tool and choose the lowest SDiv level.

    5) Select the UV Map tool and click the Morph UV button... if you're looking at the geometry you should visibly see each face as it's own shell morphing to the UV space instead of moving together as one cohesive piece.

    6) Click the Morph UV button again to see the mesh and then click Cycle UV a few times. Click Morph UV again and see if it morphs to the 2D UV space correctly. If it does you've fixed it. If it doesn't you have to repeat this process of clicking Morph UV and Cycle UV a few times until you notice the morph animation happening correctly.

    8) Return to the SDiv level you want to export and export. Remember to turn off Grp.

    9) Try importing in RC (worked for me).

    10) Yell at the wall and then report the bug to Pixologic.
    0
    Comment actions Permalink
  • Avatar
    Lucia CR
    Thanks for letting us know
    0
    Comment actions Permalink

Please sign in to leave a comment.