Pixelated texture

Answered

Comments

6 comments

  • Avatar
    Wishgranter
    Hi Stuart

    can post screenshot of RECONSTRUCTION -> SETTING so can see what settings you have used ?
    0
    Comment actions Permalink
  • Avatar
    Stuart
    Here are my settings.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Stuart

    make screenshot from UNWRAP tool settings used. ( RECONSTRUCTION->UNWRAP)

    Default values are not good in most cases. So need play with it a bit, set 16k texture and 4 MAX TEXTURES COUNT in unwrap.
    when it finish click on model and get a detailed info on results. look for TEXEL % if its under 100 % need set more textures.

    so in short start with 16k txtr size and 1 max texture count -> if the TEXEL fill is under 100% change MAX TEXTURES COUNT to 4 and UNWRAP again. If its not 100% even with 4 MAX TEXTURES COUNT, set 8 there and UNWRAP again
    0
    Comment actions Permalink
  • Avatar
    Michal | CR
    Dear Stuart,
    you have used "Fixed detail" in the default settings for unwrap. The default settings are applied when you press the Texture button but you don't have your model unwrapped already. In this case the model was unwrapped so that one texel is equivalent to 0.01 units. You can use "Maximal textures count" instead. So that it will try to find the best detail so that the unwrap will fit to the selected textures count.

    I'm not sure however if it is the problem you are observing. The easiest way how to test it is to replace your texture with a checkerboard texture and open the model. Then you check visually if each checkerboard cell is almost the same size in 3D.

    If there is a big difference then there is a problem on our side. I would ask you for the dataset in such case.

    If it is almost uniform then the problem is just in the "Fixed detail" settings and you can change default setting so that it will be unwrapped in the way you want next time you will texture your model. Or use "Unwrap Tool" to unwrap the textured model in the way you want. You can export the unwrapped model before texturing and browse the unwrapping. The texture is replaced by checkerboard texture by default when using unwrapping tool.
    0
    Comment actions Permalink
  • Avatar
    Stuart
    Here they are with a new unwrap using 4 max textures.

    Is it the texture utilisation or detail that I need to be looking at?
    0
    Comment actions Permalink
  • Avatar
    Stuart
    michalj wrote:
    Dear Stuart,
    you have used "Fixed detail" in the default settings for unwrap.



    Thanks Michal, that was simply the last settings I had tried to fix the problem, truth is I had no idea what settings to adjust.

    Setting the Max Textures count to 64 now gives me 100% in Texel detail, but there is still quite alot of pixelation in the textures.
    0
    Comment actions Permalink

Please sign in to leave a comment.