Control Points going into wrong positions

Answered

Comments

8 comments

  • Avatar
    Wishgranter
    Hi Dariusz Klimek

    How much CP projection you have there ? that mean on how much images is placed one ControlPoint ?
    0
    Comment actions Permalink
  • Avatar
    Dariusz Klimek
    Those controls are on at least 4 different images.
    0
    Comment actions Permalink
  • Avatar
    Aaron Curtis
    I have a similar problem. At first I thought it was just because my photos are bad, but look at this scene. How can point 21 be so far outside the passage?

    EDIT: oops, messed up the screenshot, new one attached.

    EDIT: new screenshot again. Was showing two green panes by accident.
    0
    Comment actions Permalink
  • Avatar
    Aaron Curtis
    Ok, I did an experiment that shows that in my case RealityCapture was not doing anything wrong.

    Control point 21 had 4 images, but only two were from the current component. I took those two images and registered them together, and then the point showed up in the right place.

    So I guess what was happening was that the other images that were used in aligning the cave wall "pulled" the wall inwards. The wall didn't line up with the control points because the wall was calculated based on more images than the point.

    Dariusz might have a different problem though.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Dariusz Klimek

    So CP its on 4 images and have at least 3 points visible on SINGLE image ?

    Can post screen of one image so can see the overall placement of the CPs there?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Aaron Curtis

    Looking on your case the main issue is the CPs are too close together, you need to place them a bit apart form each other
    0
    Comment actions Permalink
  • Avatar
    Aaron Curtis
    Wishgranter... that might be the answer to some other problem, like "why are my components failing to merge" but I don't see how it has anything to do with the issue in this thread.
    0
    Comment actions Permalink
  • Avatar
    Ben Kreunen
    I've had this a few times but narrowed it down to:
    [list=][*]Too few images with CP in current chunk
    [*]Misaligned image CP
    [*]Distortion parameters not optimal (CP near edge of image)[/list]

    The latter was mostly with fisheye images where the very outer edges of the image should be avoided for CPs but may be possible with "normal" lenses. Checking the tie points on the images with the CP may provide some clues if there are alignment issues throwing off CP locations
    0
    Comment actions Permalink

Please sign in to leave a comment.