Ortho projection of walls

Answered

Comments

25 comments

  • Avatar
    Wishgranter
    Hi antoine.lagarde

    Can you please click on the model so that I can see details of the used texturing parameters?
    What settings have you used in UNWRAP tool?

    Look at the example of what you need to see, so that I can help you...

    Screenshot 2016-04-06 18.24.53.png
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    Thanks here it is
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    so you have set low resolution for textures. Go to the UNWRAP tool and
    change it to these settings - like in the screenshot

    Screenshot 2016-04-06 18.40.00.png


    when it is done, use the TEXTURE button to generate the texture with proper settings
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    Ok should I change the gutter value aswell? I unwraped and I'm getting 69% utilization with 48% quality
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Antoine.lagarde

    Change the MAXIMAL TEXTURES COUNT to get higher TEXEL%, in the ideal case it is 100 %.
    The TEXTURE UTILIZATION is secondary information, that will never be 100 %.
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    Okay all good it's working now, is there a way I can improve the resolution on those orthoprojection, or I should build the model in many small parts and get each of them the max res texture for that purpose
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    I am not sure what are you referring to but in the ORTHO tool you can set proper settings for the ORTHO projection resolution...
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    Ok I tried a small comparison, I generated the same orthophoto with photoscan and RC, in RC I cannot get a better output than the one I have here, even if I increase texture resolution over the estimated one, the result is the same. (this is a crop in the orthophoto btw)

    How is RC doing its ortho projection, in PS for example, you don't need to build the texture or vertex colors to get it, you just go all the way to the mesh, then build and ortho projection with your desired lvl of quality and it reprojects the pictures based on the mesh and camera orientation.
    In RC you have to generate the textures so if your model is big I guess it's spread all around it and you get bad results :(
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    Can you please make a screenshot of the RECONSTRUCTION = SETTINGS = COLORING/TEXTURING sub-menu where I can see what sort of settings are you using ?
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    here it is
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Antoine

    Change the PHOTOCONSISTENCY mode to VISIBILITY
    And in UNWRAP are you using FIXED DETAIL or MAXIMAL TEXTURE COUNT setting ?
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    I'm using maximal texture count
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    Can you send me the dataset for review to milos.lukac@capturingreality.com ? So that I can take a look at what can be the issue...
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    dataset sent by pm
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    Thanks. I will download and take a look at it in the morning, when I come back from Prague.
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    Hi, could you look into it ?

    Thanks
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    Have it just run on High reconstruction. will check it when come back home and inspect the results...
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine lagarde

    You need to change one more setting for texturing part. in RECONSTRUCTION ribbon -> SETTINGS -> COLORING/TEXTURING change DOWNSCALE IMAGES BEFORE TEXTURING from 2 to 1
    1 = NO downscale is applied and use full resolution images for texture projection.
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    It was already at 1 when I run the last calculation :(
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    For coloring it's at 2 but for texturing 1 see my last screenshot
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    Try to compare it to this result: https://dl.dropboxusercontent.com/u/150 ... castle.jpg

    But in general, you need to take SHARPER images.
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    It's the best I could do with lighting conditions, but the example I sent out with photoscan is from the same dataset and comparing the 2 you can clearly see CR has reduced the output resolution, I don't know why because I don't actually know how cr does ortho projections.

    Your link doesn't work I geta 400 error :(
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    I will send you the image, as it would probably not be opened properly in the web viewer.

    In principle, your capturing scenario is not ideal. As I have written earlier, get more images, and even if you have few of them blurred, RC will filter out the sharpest ones ( if there are MORE sharp images… )
    0
    Comment actions Permalink
  • Avatar
    antoine.lagarde
    went back on a sunnier day, took sharp pictures, no blur in any of them, still can't get something better :(
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi antoine.lagarde

    send the data to me again :D
    0
    Comment actions Permalink

Please sign in to leave a comment.