Use all the photos?

Answered

Comments

22 comments

  • Avatar
    Wishgranter
    Hi Riccardo Minervino
    If you get into alignment issues, first try these settings, set all as here
    Alignment_settings_80k.jpg

    If it still does not want to align all images properly, then use a sphere with newspaper on it. Set scale, orientation etc and ALIGN it. Then select all cameras, and in ALIGNMENT->METADATA(XMP) use LOCKED ( so that all cameras and parameters are locked )
    it will export XMPs next to the aligned images. Then just move them to the other not well aligned images. Load the images in RC ( XMPs are used automatically, so you do not need to set anything ) and ALIGN the bad data...

    You need to keep the SAME names for the files and cameras, cannot change the position, orientation .. and it will work..
    0
    Comment actions Permalink
  • Avatar
    Riccardo Minervino
    Wishgranter wrote:
    Hi Riccardo Minervino

    If you get in alignment issues try these settings first, set all as here
    Alignment_settings_80k.jpg



    If it still not want align all images properly, then use help with sphere with newspaper on it. Set scale, orientation and etc and ALIGN. Then select all cameras, and in ALIGNMENT->METADATA(XMP) use LOCKED ( so all cams and parameters are locked )
    it wil export XMPs next to the aligned images. Then just move them to next not good aligned images. Load the images in RC ( XMPs are used automatically , so no need to set anything ) and ALIGN the bad data...

    You need keep SAME names for the files and cams cannot change position, orientation .. and it will work..

    Hi. I tried your settings, and it gets a bit better, i got 33/38 cameras to align. So I used the sphere (we have our own alignment object with markers), and I got all 38 the cameras, but the Metadata (XMP) option is grayed out. I cannot click on it. Is it a limitation of the demo?
    0
    Comment actions Permalink
  • Avatar
    Kruzma
    Riccardo Minervino wrote:
    ..., but the Metadata (XMP) option is grayed out. I cannot click on it. Is it a limitation of the demo?


    Yes, this feature is not available in the DEMO version of the software.
    0
    Comment actions Permalink
  • Avatar
    Riccardo Minervino
    Kruzma wrote:
    Yes, this feature is not available in the DEMO version of the software.

    That's a shame. It means I cannot continue in my evaluation.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Riccardo Minervino
    If you want, send me the data and I will process it for you ( milos.lukac@capturingreality.com ) . We have strong reasons why the DEMO cannot export some particular data... You could take 20 demo versions and calculate the whole New York in few days with RC and then just export it in one working version..
    There are many customers doing full-body and head scanning with RC, so we know they are happy with the quality and speed compared to other solutions..
    0
    Comment actions Permalink
  • Avatar
    Riccardo Minervino
    Wishgranter wrote:
    Hi Riccardo Minervino

    If want send me the data and will process it for you ( milos.lukac@capturingreality.com ) . We have strong reasons why DEMO cannot export some particular data... You could take 20 demo versions and calculate whole New York in few days with RC and then just export in one working version..

    There are many customers doing Fullbody and head scanning with RC, so we know they are happy with quality and speed compared to other solutions..

    Hi Wishgranter, thank you but I cannot send the source material as it's under NDA. I'm currently negotiating with my Company to purchase a three months license to use as test to continue the evaluation.
    0
    Comment actions Permalink
  • Avatar
    Naohiro Yamada
    Hi, Riccardo here, my company purchased a license for me, to continue the evaluation.

    I was successful in exporting the mesh and the camera's XMP.
    Now, I have another problem: I can't figure out how to properly scale and align my model

    CR01.jpg

    As you can see from the image above, I have placed control points in three different photos, and I have set a distance of 5 to all three lines.

    CR02.jpg

    However, once I import my model in Maya, and compare the ruler with a cube of 5 cm, notice how the scale is not correct.

    CR03.jpg

    Also, the orientation of my object is not what I would expect.

    How can I fix these problems?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Naohiro Yamada

    what UNITS have you set in Maya for import ? default are CMs.....
    0
    Comment actions Permalink
  • Avatar
    Naohiro Yamada
    Wishgranter wrote:
    Hi Naohiro Yamada

    what UNITS have you set in Maya for import ? default are CM.....

    Yes the Maya unit is cm.
    Btw, I'm not Naoiro, I'm Riccardo Minervino.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Riccardo Minervino :D
    why you have a different name in the profile then?????? :D
    0
    Comment actions Permalink
  • Avatar
    Naohiro Yamada
    Wishgranter wrote:
    Hi Riccardo Minervino :D
    why you have a different name in the profile then?????? :D

    It's written in my previous post, I'm using my company's account now.
    Anyway, what about the scale problem?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Naohiro Yamada
    You set 5 units = 5 meters, you need to set 0.05 ( meter ) and then it ALIGN again so that the scale change is included in the alignment.
    Then when you export data, again, take care of the PROPER units in MAYA, you need to set MAYA units to meters....
    0
    Comment actions Permalink
  • Avatar
    Naohiro Yamada
    Wishgranter wrote:
    Hi Naohiro Yamada

    Are you doing that on purpose? I told you I'm Riccardo Minervino, the user name is different because I'm logged in with my company's account... :|

    Wishgranter wrote:
    You set 5 units = 5 meters, you need set 0.05 ( meter ) and then ALIGN again so the scale change is included in the alignment.

    Then when you export data keep again care about the PROPER units in MAYA, you need set MAYA units to Meter....

    That doesn't change anything. I did exactly what you wrote, and the model is still not correct. It seems to be about 4-5% smaller than it should be.
    Also, the orientation is wrong.
    I'm gonna give this software one last chance, but it seems it's too early for it to be used in production.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Riccardo Minervino,
    got confused with the names.... do we still know who is discussing what ?
    That doesn't change anything. I did exactly what you wrote, and the model is still not correct. It seems to be about 4-5% smaller than it should be.
    Also, the orientation is wrong.

    Send me the dataset for inspection. 4-5 % should NOT be there, it’s tested quite heavily and verified that the scale is OK. It looks like a workflow issue.. Orientation is wrong ?!?! how wrong ?? any screenshots ?
    0
    Comment actions Permalink
  • Avatar
    Naohiro Yamada
    The photo and the description of what I did is the first page of this very thread, please refer to this post:
    Use all the photos?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Riccardo Minervino
    I have inspected this image: download/file.php?id=418
    and the problem is that you used only ONE image per control point so it could NOT work. You need to place a control point in 2 images, and then ALIGN it to get the PROPER scale...

    After alignment look at the CONSTANTS and there is the DISTANCE ( which you have set ) and ACTUAL DISTANCE which defines the actual real measurement...
    Try it and you will see it works properly..
    0
    Comment actions Permalink
  • Avatar
    Naohiro Yamada
    Wishgranter wrote:
    Hi Riccardo Minervino
    I have inspected this image: download/file.php?id=418
    and the problem is that you used only ONE image per control point so it could NOT work. You need to place a control point in 2 images, and then ALIGN it to get the PROPER scale...

    After alignment look at the CONSTANTS and there is the DISTANCE ( which you have set ) and ACTUAL DISTANCE which defines the actual real measurement...
    Try it and you will see it works properly..

    I don't understand why you say I put the distance points in only one image? I used three different images, or am I missing something? :?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Riccardo Minervino
    Look at the first image: download/file.php?id=418
    I can see only one image per control point.... you need at least 2 images per control point and do not need to create 3 different CONSTANTS
    0
    Comment actions Permalink
  • Avatar
    Kruzma
    Naohiro Yamada wrote:
    I don't understand why you say I put the distance points in only one image? I used three different images, or am I missing something? :?

    Hello there,
    Control Point coresponds to one point in space (on your 3Dmodel). e.g. you got dataset of some statue and you put control point named "point 0" on tip of the nose of the statue in one image, so in the second image you should put same control point ("point 0") on same place = on tip of the nose of the statue but from different angle.

    Problem is you got 3(or more) different control points on same spot on model. If you look on the ruler at 1cm in the image you got there "point 0", "point 2" and "point 4" that's 3 different CPs for one point in space.

    It should be like this:
    CR01_.jpg


    But how to add same control point to different images? There are 2 ways I am aware of:
    1) Select CP in one image and then you can add same CP to other image
    2) Drag and drop CP from 1Ds view

    And you got another mistake there (I think it is mistake) : distance between 1 and 5 is 4cm not 5cm.

    I hope this helps.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi
    Take a look at the video with control point workflow: https://www.youtube.com/watch?v=d8naLEtLqDY
    0
    Comment actions Permalink
  • Avatar
    pablogaton

    Naohiro Yamada,
    I think you should bother to learn the program a little before asking. Here there are people wanting to teach and learn but the minimum is to bother before, and not ask for things as if it were forced to respond.

    1
    Comment actions Permalink
  • Avatar
    Tom Foster

    On the contrary, you can look at all the documentation and still be puzzled, even if not, it's v valuable to be helped through the process, so it's expressed in a different set of words, for everyone's benefit.

    Me, I'm bookmarking this thread. Thanks for reviving it.

    0
    Comment actions Permalink

Please sign in to leave a comment.