random cut-throughs in combined scan with 22 pictures

Answered

Comments

13 comments

  • Avatar
    Wishgranter
    Hi Felix De Lille
    Are you sure that images are properly aligned with the laser data ? Is your target to get the laser data reconstruction and images for coloring/texturing the resulting mesh ??
    0
    Comment actions Permalink
  • Avatar
    Felix De Lille
    Thanks Wishgranter,

    Yes i think they are properly aligned because the have a location and direction in the 3D view (together with the laser cube, see blue cirkeled). I need also pictures for reconstruction because it needs to create polys behind the objects that the laser didn't see.

    another viewport from inside that building as example:
    1 scan only (you can see no polys behind the monk):
    Image

    1 scan + 22 images (the space behind the monk has polys but the same cut from on the roof also cuts).
    Image

    1 scan + (more) 80 images and colored (the cut-throughs are not at same places as the 1 scan + 22imgs).
    Image

    Greetings
    Felix
    0
    Comment actions Permalink
  • Avatar
    Michal | CR
    Dear Felix,
    are you using reconstruction region for reconstruction? If not then try to use it and the rectangular shaped "cutouts" should not be there. The fix of this issue will be released soon but meanwhile please use the reconstruction region prior to model computation also for large scenes.

    The missing monk is another task. Was the monk removed after scanning and before images capturing? Or it was all the time the same static scene. Because it seems to me that he was removed. If so then of course he is not in final reconstruction because RC's results should be visibility-consistent.
    0
    Comment actions Permalink
  • Avatar
    Felix De Lille
    Thank you , i did that and the cutouts are gone :)
    The monk was never moved.

    I rendered on colored mesh because textures is not efficient (many squares).
    Seems still quite good for 1 laser scan and 80pictures. I think i just have to take more pictures:
    Image

    Just 1 problem: when i import the obj (1.8GB) in autodesk remake i get this:
    Image

    Greetings
    Felix
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Felix De Lille

    I rendered on colored mesh because textures is not efficient (many squares).


    Can you post any screenshots ? It could be just an issue regarding proper UV mapping settings...
    0
    Comment actions Permalink
  • Avatar
    Kruzma
    Felix De Lille wrote:
    I rendered on colored mesh because textures is not efficient (many squares).

    Hi felix,
    this should be solved using 'Adaptive texel size'. You can find it in reconstruction settings or unwrap tool.
    This unwrap style is useful, when you got scene with different detail e.g. statue in some public place: statue is taken in high detail but the background isn't as detailed as statue. So if you use fixed texel size, statue will be unwraped with same texel size as background, so you will probably get not sufficient resolution for your statue.

    adaptive.png


    Felix De Lille wrote:
    Just 1 problem: when i import the obj (1.8GB) in autodesk remake i get this:
    Image

    This is correct, because RC creates watertight meshes... your scene should be inside that box :).
    You just need to remove unwanted triangles (inside RC using filtering tool).
    0
    Comment actions Permalink
  • Avatar
    Felix De Lille
    Thanks Kruzma, wishmaker,

    I changed unwrap parameters to 'Adaptive texel size' and it's better (at least for backgrounds).
    Just the objects are not.
    All these are again 'rendered to picture':
    Image
    Image
    Image
    Image
    It's a tiny room but i only took 75 pictures.

    I guess i will have to go back and take 500 pictures..
    I have a canon EOS 50D, tripod and a Canon EF-S 10-18mm f/4.5-5.6 lens.
    What is the ideal focal length to shoot at for that lens?
    I would put it on f/9.0 ? I'm a noob in photograph. The room is pretty low of light.

    Greetings
    Felix
    0
    Comment actions Permalink
  • Avatar
    aure
    Hello Felix!
    Any chance you're living in Lille (France) or its just your name? ^^ because i'm in Tournai ... so might be nice to meet IRL ^^

    For pictures, best settings i found:

    Set iso value as low as possible, and keep it all around the run.
    focal length should be fixed too, around f11 to avoid deformation as much as possible.

    So only thingh you can play with is time exposition, so better use your pod ;)
    0
    Comment actions Permalink
  • Avatar
    Felix De Lille
    Hi aure,

    Thanks, i had ISO on 100.

    haha, no i live in Oudenaarde which is only 40min drive from you which is also close. I will send you a PM
    0
    Comment actions Permalink
  • Avatar
    cfl001
    Hi Felix,

    I've had the same issue as you with regards to cut through lines sporadically across my models, see thread with screenshots here: Anybody know why this keeps happening to my models?

    I have still not managed to solve it and I don't fully understand how you fixed it. Could you explain in a bit more detail, it would be much appreciated!

    Regarding texturing of your model, I think you need to tweak with the different unwrapping and texture settings, as you can definitely get a higher quality texture than you currently have with 55 photos. I don't think the issue is not having enough photos. Let us know how you get on either way!
    0
    Comment actions Permalink
  • Avatar
    Felix De Lille
    Hi cfl0001,

    Thanks i tried with gutter 5 unwrap tool but didn't help.
    in recon settings i have this:
    Image
    It's hard to know what to tweak, even with the documentation (if you are noob).

    About the cut-throughs, yes setting the bounding box before reconstruction (manual or auto doesn't matter) did the trick.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    To overcome it, create RECONSTRUCTION->RECONSTRUCTION REGION before you run reconstruction.. then it should be not visible.. try it and report to us back if that helped..
    0
    Comment actions Permalink
  • Avatar
    admin
    Thank you for the post,
    This is known issue. There will be fix for it for sure! However, to avoid it:
    1. use bounding box = reconstruction region.
    2. if it happens despite that then change "RECONSTRUCTION \ Settings \ Minimal distance between two vertices" to preferred vaule. If you model is georeferenced then the value is in meters/feets otherwise you must quess ... usually 0,001 works well. However, the best way ( if you don't have your scene georeferenced ) is setup scale an then set the parameter according to the scale. Or you can use optimal texel size visible in unwrap tool too.
    0
    Comment actions Permalink

Please sign in to leave a comment.