Comments

9 comments

  • Avatar
    Lucia CR
    hello,
    what exactly is the problem?
    0
    Comment actions Permalink
  • Avatar
    cfl001
    Hi Lubenko,

    There are gaps in the model, in a grid like shape all around. It has happened in other projects too.
    0
    Comment actions Permalink
  • Avatar
    chris
    I have seen this once or twice...

    are you mixing aerial (uav) and ground level photos?

    and the merging components based on control points? or did it all work in one go?

    also dose it export like that or is it just viewport in rc?

    looks potentially like miss aligned photos, or components.
    0
    Comment actions Permalink
  • Avatar
    cfl001
    Hi Chris,

    In past projects it occurred when mixing UAV (Phantom 4) photos with ground photos. I learned the hard way that it was not just in RC but also in the exported mesh, which looked super messed up once finished reconstructing (which took ages).

    The screenshot above is from a different project, however, it was just UAV images. There's about 6 different groups of photos, and I've used about 10 control points in around 18 photos. Each photogroup I've chosen the first middle and last photo to have the control points in to ensure everything was tied in correctly.

    Perhaps I am overdoing it with control points? I might restart the project and realign it with no control points, and then add control points until the model aligns itself into one component.

    Could this be a hardware or reconstruction settings issue?
    0
    Comment actions Permalink
  • Avatar
    Lucia CR
    it looks similar to this: Random cut-throughs in combined scan with 22 pictures
    0
    Comment actions Permalink
  • Avatar
    cfl001
    From the thread linked above:

    michalj wrote:
    Dear Felix,
    are you using reconstruction region for reconstruction? If not then try to use it and the rectangular shaped "cutouts" should not be there. The fix of this issue will be released soon but meanwhile please use the reconstruction region prior to model computation also for large scenes.


    I'm not sure I understand this? Does this mean setting the boundary/region for constructing the model? What if I need the full model?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi cfl001
    Just create a bounding box (BBox) that covers the whole model or even a bit larger area to fit it there... Do it please and report back..

    We have reproduced it here on some data and the fix is currently being worked on, but do what I have recommended, it is much more about how it works when the BBox is used and processed this way, the BBOx should fix this..
    0
    Comment actions Permalink
  • Avatar
    cfl001
    Hi Wishgranter,

    Just wanted to confirm that I rebuilt the project and this time used a bounding box and it appears to have solved the issue.

    This bug was actually super annoying when it happened and and as we were pushed for time it forced me to drop RealityCapture and use ************ instead for this particular project which was especially frustrating as I really liked RC up until this bug!

    I'm back to using RC again now though as I really like the UI. I hope this bug is resolved soon to prevent other people from having the issue. It's super frustrating leaving the PC work overnight only to return to a buggy model.

    All the best.
    0
    Comment actions Permalink
  • Avatar
    admin
    Thank you for the post,
    This is known issue. There will be fix for it for sure! However, to avoid it:
    1. use bounding box = reconstruction region.
    2. if it happens despite that then change "RECONSTRUCTION \ Settings \ Minimal distance between two vertices" to preferred vaule. If you model is georeferenced then the value is in meters/feets otherwise you must quess ... usually 0,001 works well. However, the best way ( if you don't have your scene georeferenced ) is setup scale an then set the parameter according to the scale. Or you can use optimal texel size visible in unwrap tool too.
    0
    Comment actions Permalink

Please sign in to leave a comment.