Align laser scan with images

Answered

Comments

12 comments

  • Avatar
    Wishgranter
    Hi Alastair MacColl

    1. The prior pose of the laser scan has the correct XY co-ordinates, but the Z reads 0 instead of the correct ~220m in the absolute co-ordinate - not sure if this is the problem? I have manually changed the z value to 220m and re-run the Align tool without success.


    So the data has been registered in an external application with a projection system ? have you set that it is GEOREFERENCED data on IMPORT of laser scans?

    2. The laser scan also appears to be have very few points in the 3D view (and the 'Features' parameter reads 382), but the source E57 has approximately 18 million points. Does it sound to you like the LSP is being read in correctly?


    That is absolutely OK, we do not load all points, we convert the data to our own LaserScanPicture format ( *.LSP ) but for performance and other reasons you see only FEATURES detected in the scans, not full-resolution load of data, as it would be highly impractical. The *.LSP format contains ALL original scanned data... You will see that, when you use reconstruction, all data are present there...

    I have a small project (84 images and 1 laser scan), whereby alignment of the images has worked fine but I can't make the laser scan align with the image model. Currently I have two components, one with the 84 images and the other with the single scan. I feel like I'm missing something simple here but the laser scan isn't aligning and I can't see how I can add control points to match the two components.


    Only a single laser scan used, scanned with COLOR or just intensity ??
    As for the control point workflows, take a look at this short video: https://www.youtube.com/watch?v=d8naLEtLqDY
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    I have the same Problem with a small scan.
    The scan has been made available to me in ptx as well as e57.
    I do not know yet if it contains color information.
    Here is one example from the ptx, which I managed to open with the editor:
    -2.271898 1.055065 -1.921448 23172.000000

    Import with both files, color or intensity does not make any difference.
    Repeating alignment several times does not help either.
    The image-model is perfect according to the alignment report (I import the laserscan first though) and quite sturdy according to inspection.
    Both cover pretty much the same area and have a distinct geometry (simple base of a wall respond in a church), althought some small areas are missing in the laserscan due to the position of the scanner.

    I do not have any coordinate info on the image model, since I wanted to use the laserscan for that purpose.
    I tried using control points but I don't know how to define them in the scan, since there is only one greyscale image (I guess intensity) in the e57 import (_1 added to the file name by RC on import) plus one entirely black image (_5 added).
    The ptx results in only one very grizzly image where I cannot mark anything with any kind of accuracy.
    Dragging control points into 3D view did not work as well as positioning them in there directly by clicking.

    Any suggestions?
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Hello?
    Anyone?
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Got the same dataset with color information now but it is the same difference - images and laser scan stay in separate components.
    I could really use some help here!
    0
    Comment actions Permalink
  • Avatar
    Gavagnin Andrea
    Götz Echtenacher wrote:
    Got the same dataset with color information now but it is the same difference - images and laser scan stay in separate components.
    I could really use some help here!


    Can you share some screenshot of your problem?
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Hi Andrea,
    thanks for the reply! :-)
    The attachment is a composition to be able to show as much as possible.
    Deactivating the black image in the scan did not help either.
    Coordinate system in settings is set to euclidean as well, btw:
    Relative pose: Exact
    Relative coordinates: local:1 - euclidean
    Absolute pose: Locked
    Absolute coordinates: local:1 - euclidean
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Could it be that "Use camera positions" (gps) set to "True" in the alignment settings of the image component is the cause?
    It confuses me anyway because my camera does not have this feature...
    "Lock pose for continue" in image options is "False", "Locked pose group" is empty and "Absolute pose" is "Unknown'".
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Götz
    1. import them as EXACT
    2. select the scans in the 1Ds and change their PRIOR POSE->ABSOLUTE POSE to LOCKED and you will have the proper scan positions
    EXCACT_LOCKED.png


    3. the scans are without color information ( was the model scanned without color ?? )

    -2.271898 1.055065 -1.921448 23172.000000 - first 3 values are positions and the last one is an INTENSITY value. there would be 3 additional values for RGB information....
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Hi Wishgranter,

    thank you very much for looking into the matter! :)

    1. I did that (screenshot - import window).
    2. It is set to Locked automatically.
    3. Yes and no. Color information is also available but not very good - and it didn't make a difference with aligning (with i5).

    The position wasn't the problem, I figured it out after a couple of tries.
    But I just didn't manage to align it with the images at all, even though I did try quite a bit - and read around in the forum of course...

    My new questions:
    A. Did LAserscan and images align for you?
    B. Is it possible to align with intensity only? I thought so since there is a dropdown during import...

    Thanks again,
    Götz
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Götz
    A. Did LAserscan and images align for you?
    B. Is it possible to align with intensity only? I thought so since there is a dropdown during import...

    No, they could not be aligned, it needs control points, you must use color information. the INTENSITY data is NOT the same as when you use RGB-GRAYSCALE conversion. that means in the INTENSITY channel the data look quite differently from RGB images.
    but I highly recomend you to use higher scanning resolution + larger portion of the scene on the scans + COLOR + at least 2 positions...
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Hi Wishgranter,

    aha, that helps, thank you!
    The resolution should be fine in the highest increment - about 14000 points (correct me if I'm wrong).
    I will try with color in the highest resolution then.
    In this case, there is only one position available - do the same rules of several positions also apply to laserscans?
    What if the cloud has already been joined and positions are no longer available?

    I thought that the geometry should be distinct enough for RC to get it matched - or how does this work?
    Is it rather a matter of number of points?

    How did you set the control points in the scan? That did not work for me at all.
    Also, isn't it kind of pointless (pun not intended), since I want to use the precision of the scan?
    With the control points, I won't get a very high accuracy, since it is quite hard to pinpoint distinct features (again, please correct me if I'm wrong).
    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Hey Wishgranter,

    so how does RC align laserscan and image based model - only by color or also by geometry?

    Also, how do I set control points in a scan - I did not manage that at all...
    0
    Comment actions Permalink

Please sign in to leave a comment.