Control points acting erratically, illustrated

Comments

4 comments

  • Avatar
    Götz Echtenacher

    No, I have not.I have seen ridiculously high errors and also the notorious 100 in a VERY difficult project (images pulled from the net) but they always went away after alignment. I also did not notice the correlation to just one point.

    I would definitely call that a bug!

    Do you still have the state with the offending CP? If yes, how do the distortion grids look like? Does it go away if you delete the weird component and align it again? The thing is that there is some randomness in the alignment process which gets noticable only when the model is borderline in terms of finding a solution (not quite ideal) - which is not surprising given the amount of metal and unicolor surfaces...

    0
    Comment actions Permalink
  • Avatar
    Kevin Cain

    Hello, Götz,

    As RC has been crashing regularly the past days during alignment on this project, I don't have the intermediate state shown above but will take a look at the distortion grids as you suggest if I can get another clean example.

    I'm trying to understand why RC keeps crashing -- clearly it relates to control points since I am starting with the same image set in a fresh project each time:  the project used to align fine, but after adding needed control points to address alignment deficiencies, I haven't been able to run a single align without one (or several) core dumps.  The control points are all 'legal', and I've verified them several times.

    I suspected that this could be factor -- but it seems from your comment that alignment cured your obscenely high pixel error, and did not crash the program.

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Yes, definitely no crashes, at least no core dumps, maybe an unexpected propram termination or so, but that can always happen.

    So you didn't have any issues with other projects before? Can you still run/align those without issues? That would exclude some problem with your setup.

    0
    Comment actions Permalink
  • Avatar
    Kevin Cain

    Yes, it's not the system.  I can go back to previous versions of this project, and it aligns fine.

    But once I have ~200 total CPs, RC either fails to complete (stalling after several hours) or crashes outright.

    After trying for several days, it's getting very depressing.

    1
    Comment actions Permalink

Please sign in to leave a comment.