Export OBJ vs Upload to Sketchfab Directly

Answered

Comments

23 comments

  • Avatar
    Götz Echtenacher

    Hi Fernando,

    you are doing nothing wrong! The large triangles are a result of the way RC generates the mesh. I think they are working on a way to avoid those artifacts, but for now we have to live with it. You can reduce the size of the bounding box slightly and use the filter "mark triangles outside box" to delete them.

    Can't help you with the texture problem though...

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Thanks a lot of Götz!

    I have repaired the artifacts as you said.

    However, is important know why the OBj exported is not working propertly (probably some config ?).  Is very different the exported obj and the uploaded directly. I need work the models porccessed in meshmixer. If not.

    For example,  not only the textures are wrong, mapcats shows diferent too.

    For the exported OBJ and uploaded manually:

     

    And here an screenshot for the model uploaded directly:

    Anyone knows why?

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Fernando,

    have you looked at the obj locally with another software before uploading to sketchfab? The look reminds me a bit of meshlab, where by standard texture and vertex color is switched on simultaneously which results in too dark a look - switching one of them off will fix that.

    I did not understand the differences in geometry - the first screenshot shows a completely different part of the model and is also textured...

    If it works fine directly from RC, why do you need to do it manually?

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Hi Götz,

    Yes, i have imported the model in meshmixer and the look is similar than sketchfab.

    My workflow is export the model and import it  in meshmixer for postproduction purposes, and then upload to sketchfab or 3DPrint.

    I don´t have control for model uploaded directly with the "upload to sketchfab" option. For example, control the number of the tiles and the size, control the size of the model, etc and via "upload" i don´t know what i´m uploading.

    I have uploaded several models with diferents options in the export mesh window, but similar results

    Thanks!

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Sorry, I don't know what it could be out of the top of my head. Does that happen with other projects too? It might help if you post a screenshot of your texturing settings and maybe some export settings as well.

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Yes. I tried some diferent options but nothing

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    And the obj export settings? Did you try to set Export Vertex Colors to False?

    Do you observe the same behavior with other project?

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Settings:

    vertex colors off:

     

    vertex color on:

     

    Is my first model with this program. 

    I don´t know how to solve this.

     

     

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hmm, I use Number Format: Double - no idea why, it's always been like that.

    Also, I don't export normals.

    Have you tried using a larger Maximal Texture Resolution?

    I don't have any experience with Sketchfab (although I should). Could it be that it wants one texture file only?

     

    0
    Comment actions Permalink
  • Avatar
    Fernando

    HI

    I have compared two mtl files, the generated with RC vs Others

    #
    # Wavefront material file
    # Created in RealityCapture v1.0.2
    # www.capturingreality.com
    #

    newmtl Monsalud_cuarto_Material
    Ka 1 1 1
    Kd 1 1 1
    d 1
    Ns 0
    illum 1

     

    Where said Kd i replace for Ks and now is viewing fine in Meshmixer. Now  i´m uploading to sketchfab, i´ll reply when uploaded.

    Best

    Fernando

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hey Fernando,

    wow, nice idea!

    Did it work?

    Anybody any idea what's going on here?

    If not, I think you should report it as a bug.

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Hi Götz,

    Work, but texture shows terrible. Very low quality. I don´t know what's hapening :(.

    If i export the texture with only one file, the model shows propertly as you said (locally in Meshmixer and remotely in Sketchfab).

    If I export the texture of the model in parts, the model and the texture don´t show propertly (locally and remote).

    I don´t know if there are one forum about bugs, i think so. If so, i will post this issue.

    Oh, here is the model: https://sketchfab.com/models/d35e6c55a8f74507811b6b43b1d71de0

     

    Thanks a lot!

    Fernando

     

    0
    Comment actions Permalink
  • Avatar
    ShadowTail

    Could it be that you are, in that case, viewing the model with vertex colors only ?

    For "low" resolution meshes that can result in looking like the texture is of a terribly low resolution.

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Hi Shadow

    I don´t think so.  

    As said, the diference is if export texture as only one jpg file, it's show fine. But if export texture as parts, it´s show terrible.

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    I don't think its vertex colors, the mesh has a much lower poly count.

    Fernando, did you try the texture resolution 16k x 16k?

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Hi Götz,

    No, i don´t try 16kx16k because i choose 42 jpg parts textures, and 16x16x42 is huge. 42 parts in 2x2k

    In this moment i´m rendering another model for testing. 

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Fernando,

    the thing is that you would need only ONE 16k because 2k fits in there 64 times (8x8) !  :-)

    So I would try 16k or at least 8k - that should give you a better resolution if you force it to put everything on one texture file.

    0
    Comment actions Permalink
  • Avatar
    Fernando

    Hi

    Just render another model, and verified the issue:

    Here, an screenshot of the model just generated the obj, without change anything int the MTL file.

    Here, an screenshot of the obj file opened in Meshmixer. Left side, with single JPG texture, and right side, exported with multipart jpg texture and replaced in the MTL file the Kd word for Ks word.

     please, see 100% size: https://support.capturingreality.com/hc/user_images/fQ3oTzQcObGCj9wpEEGNKA.jpeg

     

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    The bottom left one looks ok to me. So is that the 16k version?

    0
    Comment actions Permalink
  • Avatar
    Fernando

    bottom left Is 16K ONE file version

    Botton right is 38 tiles for 2048K each tile 

     

    0
    Comment actions Permalink
  • Avatar
    thomas.flynn

    I'm a bit late to the party but to adress the OP's original issue, I think all that's required is to turn off vertex colors in Sketchfab's 3D settings: https://help.sketchfab.com/hc/en-us/articles/210765623-Vertex-Colors

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    better late than never :)

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    hehe, that's quite true!

    0
    Comment actions Permalink

Please sign in to leave a comment.