Scale

Answered

Comments

19 comments

  • Avatar
    Wishgranter
    Hi Adam Rountrey

    Can you make a screenshot of the EXPORT settings for PLY/OBJ?

    For the proper scale in an external application, as we have observed many times, you need to figure it out by testing what units need to be set so that the scale is PROPERLY imported. If you remember, someone has already mentioned issues with Meshlab + few other sw solutions.

    Is it possible to send me, say, a 1 mil triangle model so that I can check it in Geomagic?
    Please send it to milos.lukac@capturingreality.com

    If you set scale bars properly and then align, the scale is set properly, as we have tested it many times…
    0
    Comment actions Permalink
  • Avatar
    Adam Rountrey
    Thank you for the quick reply.
    Yes. I will send model tomorrow. The coordinates in the OBJ (opened with a text editor) are too small (all with absolute value less than 2) to represent the distance I put in as a constraint (81.87 units).

    Untitled.jpg
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Adam Rountrey

    OK, send it…

    And try changing PRESERVE COORDINATES to FALSE in the meantime...
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Adam Rountrey

    Reading your email, you need to set the scale to mm but RC default units are meters.
    So your scale constraint needs to be set to meters -> 0.08187 and not 81.87.

    When you change a constraint, you need to realign and reconstruct the model or change the import units in Meshlab to mm.
    But if you have used UPDATE in between, I highly recommend you to realign and reconstruct the model…
    0
    Comment actions Permalink
  • Avatar
    Adam Rountrey
    I set the constraint distance to 0.08187, realigned, and reconstructed. The resulting exported model has the same scale as the one produced when scale was 81.87. I also tried changing "Preserve Coordinates", but I get the same result both ways.

    Thank you for your continued help on this problem.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Adam Rountrey

    Please read the email with screenshots for confirmation on the issue.
    0
    Comment actions Permalink
  • Avatar
    Andrzej Poznanski
    Any solution to this?

    I just tested on latest RC (1.0.2.1978). I set distance between two control points as 100, aligned, built mesh, exported as mesh1, then changed the distance to 10000, aligned again, built mesh, exported as mesh2. After import to 3rd party app (Unreal in my case), both meshes show identical scale.

    -Andrew
    0
    Comment actions Permalink
  • Avatar
    admin
    Hi Andrzej,
    thanks for reporting we will check it.
    0
    Comment actions Permalink
  • Avatar
    jack
    Hi I have this problem too, posted in Bug reports
    0
    Comment actions Permalink
  • Avatar
    jack
    Was wondering if there was any news on this?

    Would it be easy to roll back to a previous version of CR before the update?

    Thanks
    0
    Comment actions Permalink
  • Avatar
    Callum McKain
    Any further action on this? i am getting the same problem...

    scale set to 0.53, aligned and exported and scale is wrong in Autodesk Recap. Changed distance to 0.0053, aligned and exported and the scale is the same as when it was exported the first time...?
    0
    Comment actions Permalink
  • Avatar
    rstuckey
    Unfortunately, I am having a scaling problem too. I am using laser scan data and images.


    I cannot seem to find the "preserve coordinates" check box, often referred to in previous posts, has it been removed?
    0
    Comment actions Permalink
  • Avatar
    Sung
    I am having trouble with this as well. RC seems to ignore scale when exporting to mesh. I have tried both coordinates and tie points methods. Any news on this front?
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi all
    When you use just images and set scale using control points, then you need to REalign the scene so that it’s included in the project. when you don’t do this, then the scale is NOT applied and you won’t get proper scale
    If you use data from laser scanners, then the SCALE is set properly, as laser scanners always export in metric scale ( or imperial depending on your laser scanner software settings )
    If you still have issues, please make a proper report on your workflows so that we can find the issue and correct it...
    0
    Comment actions Permalink
  • Avatar
    Sung
    I apologize for my short post. I wanted to see if this was a common issue before writing a in depth explanation.

    Setup
    Image
    I have 4 markers on the floor 1 meter apart from each other.
    I am considering z as up.
    Coordinate system set at Local:1-Euclidean.
    Applications used for measurements = Rhino & meshmixer
    Camera: Iphone 6S

    Workflow 1 (TP)
    TP - CP's & distances placed before alignment.
    1. Set CP (Type: Tie Points). point 0 and point 2. Minimum 4 images per each point.
    2. Define distance between points 0 and 2 as 1 meter.
    3. Align.
    Continue rest of workflow

    Workflow 2 (TP)
    1-3 same as workflow 1
    4. update
    continue rest of workflow

    Workflow 3 (GCP)
    1. Set GCP Point 0 - 4. Minimum 4 images per each point.
    2. Set Type to Ground Control
    3. Input coordinates (show in image)
    4. Align
    Continue rest of workflow

    I have tried all 3 and none of them are producing the correct scale. Also when using GCP's the orientation of the model comes out incorrect. Am I doing something wrong?

    Also, I saw in another post that RAD markers might be in the pipeline. Any news on that? Thank you.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Sung
    I don’t have experience with Rhino or Meshmixer, but from other sw packages we know there’re some issues regarding PROPER scale import. 3Ds max is working, Maya is working and other sw, too... in Maya you need to set it from cm to M and it’s working properly...

    When you use Workflow 1 and 3, then it’s WORKING, as we’ve tested it many times.

    Look for import settings in the software you use, if you can eventually change units for imported files.
    I’ve even seen that you need to set CM to get proper scale in METERS, which are our units....
    0
    Comment actions Permalink
  • Avatar
    Thomas Van Damme
    I'm having a similar scale issue, but with orthophotos.
    Workflow was as follows:

    1. Align images
    2. Mark 4 control points (each control point is picked in 4 pictures, they are points on a scale bar)
    3. Create 2 distances between these control points as constraints
    4. Update

    I haven't checked whether the actual 3D model is to scale after export, but at least when I open the ortho view in RC the "unit bar" at the top of the view is way off, and doesn't seem to have adapted after clicking "Update".
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Thomas Van Damm



    1. Align images
    2. Mark 4 control points (each control point is picked in 4 pictures, they are points on a scale bar)
    3. Create 2 distances between these control points as constraints


    4. ALIGN again to get correct scale etc.

    You need to use ALIGN again so that the constants are included in alignment solution, the UPDATE is used when you have set everything properly and need to change the PROJECTION SYSTEM, it is not set for setting proper scale.....
    0
    Comment actions Permalink
  • Avatar
    Lucia CR
    Just a side note - it is supposed to work like this: The Update option changes solely the coordinate system of the currently selected component and it also updates the scale of all children models, whereas the Align Images (F6) button creates a new component.
    0
    Comment actions Permalink

Please sign in to leave a comment.