image planes to MAYA export

Answered

Comments

13 comments

  • Avatar
    Wishgranter
    Hi Frank Zwick

    It is in the MAYA exporter, so if you load an exported MAYA scene, you will get everything set OK. If you have problems to load bigger projects into MAYA, then you need to change the viewport renderer 2.0 to older one. It seems the driver is not prepared to load big data, or it is a bug...
    0
    Comment actions Permalink
  • Avatar
    Frank Zwick
    thank you wishgranter, but if i export the mesh, i can only set .obj, .ply, .xyz and part list as exportformat!?
    so where can i find the maya-exporter?
    I am using the promo-version latest build...
    0
    Comment actions Permalink
  • Avatar
    admin
    Hi Frank,

    to export cameras you need to go to ALIGNMENT (or WORKFLOW) tab and select "Registration" in export panel. In the export dialog select "Maya 2013 Ascii scene" format.

    This will export camera poses and un-distorted images.
    0
    Comment actions Permalink
  • Avatar
    Frank Zwick
    ahh ok, thank you!
    0
    Comment actions Permalink
  • Avatar
    Frank Zwick
    hello,

    after doing some tests, i still can`t get proper data into maya!

    The overall orientation is wrong, but this is not a big issue, i can group and rotate all cams (rot.x -90).
    The overall scaling is wrong, can also be fixed by grouping and scaling (scale.xyz 0.1).
    The position of all cameras ist correct but they are aiming is wrong! Looks like they are pointing all in the same direction (+z) instead to the center i my case (FullBodyScan).

    What did i do wrong? Which settings do i need to get proper data into maya?

    By the way, the export of the mesh as obj works fine, it keeps the additional info of GroundPoint and Distance, only the Orientation is wrong (rot.x -90).

    regards
    Frank
    0
    Comment actions Permalink
  • Avatar
    Frank Zwick
    ...still no success...looks like exported cameras have right position in space, but orientation of the individual cameras (camera look at) is wrong...

    some hints for me, which settings to use for a proper import?

    regards
    Frank
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Frank Zwick

    We have tested it very carefully, it is working properly. Can you send some screenshots from RC and Maya and highlight the actual issue?
    0
    Comment actions Permalink
  • Avatar
    Frank Zwick
    Hello Wishgranter,

    doing the same task again today, now CR exports all cams with correct orientation!
    All i have to do now, is to group all cams and rotate the group X-90 and everything looks fine...problem solved!
    anyway here are two screenshots from last week and today (same CR-Project-data!):

    Cams_in_Maya.PNG


    Cams_in_Maya_ok.PNG



    regards
    Frank
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Frank Zwick

    You can set the Z-Y rotation axis in Maya settings – this way you can get a PROPERLY oriented scene to Maya… And therefore you do not need to rotate anything…
    0
    Comment actions Permalink
  • Avatar
    chris
    Hi,

    I am also having a similar problem with the Maya export - a straight forward registration export works fine, with all the cameras orientated correctly. However as soon as a try and impose a scale/control points within the RC scene and export I get an import error dialogue in Maya and whilst my cameras are positioned correctly they do not have the correct orientation.

    Any thoughts?

    Many thanks.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Chris

    When you set control points ( at least 2 images per CP ), do you use UPDATE or you REalign the scene ??
    Because when you use UPDATE, the scale will not work… You need to realign the scene to apply the scale. Then it will work, tested many times already...
    0
    Comment actions Permalink
  • Avatar
    chris
    Thanks for your reply.

    I have not pressed update - import folder of images, create control points (3 points in 4 images each), align images, select cameras, Maya export. In Maya Translation OK but not orientation. This does not happen if I do not lock the CPs, but then I loose scale and orientation in Maya.

    Can email images if needed.

    Many thanks again
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Chris

    send me the screenshots to milos.lukac@capturingreality.com
    0
    Comment actions Permalink

Please sign in to leave a comment.