Unwrap settings

Answered

Comments

6 comments

  • Avatar
    Wishgranter
    Hi Yoz

    But i don't know the next steps, what are the best settings for unwrap tool ? I have made a first try, with setting fixed detail (1cm), then generated textures and exported OBJ file (1Go).


    There are no best settings :D

    Simplification set to 15 million triangles is OK.

    As for the settings you have used (fixed - 1 cm), it is mostly OK for GIS. But depending on the model size, the texture can be still pretty big. And that is then the problem regarding your GPU RAM.

    Best if you set 1 cm, and set a 4-8k texture size, because 4-8k textures are easier to manage by your GPU and can work easier with it in an external application. This can be a problem as many external applications are not prepared to handle too big textures (8k+).
    Set GUTTER to 1 (2 pixels among UV islands, more effective texture space use).

    Try these settings and report back if it has helped to solve it…
    0
    Comment actions Permalink
  • Avatar
    yoz
    Hi,

    I have already try these settings :

    - fixed detail = 1cm
    - txtr : 4k txtr (89 txtr counts)
    - gutter = 2

    Result : OBJ file = 1.5Go, unable to load on any sw

    I will try to simplify the model to 10M tri, and apply settings : fixed detail 1cm / txtr 4k / gutter 2

    About GPU RAM, 8Go from 2GTX970 is not enough ?

    I have already ask for this, but what sw can you recommend me to load big models ? I don't why OBJ files load under Acute3Dviewer are so ugly (and not georeferenced). When textures render will be disponible directly under RC GUI ?

    Thks for help :)

    Regards.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Yoz

    4k texture = 89 pieces.. It is a LOT of texture. Set the texture resolution to 2cm pix and you will get a 1/4 resolution of the resulting texture.

    About GPU RAM, 8Go from 2GTX970 is not enough ? = No, as these are 2x 4 GB cards and you cannot count it as a 8 GB RAM...

    Depending on the project, even 2 cm resolution is enough...
    0
    Comment actions Permalink
  • Avatar
    yoz
    When you say "set txtr resolution to 2cm", it's the fixed detail setting in unwrap tool ?

    What do you mean by "get 1/4 resolution of resulting texture" ?

    About GPU RAM, 2x4Go it's your own config :) You recommend me a GTX TITAN X ? (12Go Ram / 3k cores) ?
    Always about GPU, is this necessary for RC processing to put the SLI cable between the 2 GTX and use it ?

    Regards.
    0
    Comment actions Permalink
  • Avatar
    yoz
    Hi Milos,

    I have made some new tests.

    Here my last test :

    screenshot1.JPG


    As you can see, i have txtr counts @8k, gutter 1 and txtr quality @100%

    But here is the result of the OBJ export (huge files) :

    screenshot2.JPG


    It's impossible to open the OBJ file on any of my viewer (cloudcompare, 3dreshaper, acute3dviewer), too big ! Furthermore, the OBJ seems to be not georeferenced, then i have checked georeferenced export in RC.

    And if i export in PLY file, i have a very bad quality export.

    HELP !!!!

    How to show a good quality 3d model with textures to my customers ?

    Thanks in advance.

    Best regards.
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Yoz

    It’s because you have still a LOT of textures used and the viewer’s not prepared to do OPTIMIZATION to show a full-resolution model. So you need to set an even larger detail to get it done. For presentation it’d work even with a bit lower resolution as it’s for reviews only...
    Depending on the project size, I think even 5cm resolution should be OK.

    So you need to try out few more settings on UNWRAP with fixed detail and increase it to 5 cm resolution to get a lower texture size… and I highly recommend you to close all applications except the one where you’re opening the 3D model, as it eats the GPU RAM ( even web browsers like Chrome, Firefox, Internet Explorer etc. )
    0
    Comment actions Permalink

Please sign in to leave a comment.