Texturing artifacts when importing a model in Unreal 4

Answered

Comments

8 comments

  • Avatar
    Wishgranter
    Hi Florin Barbuceanu
    Is the model georeferenced ?

    go to WORKFLOW->SETTINGS->COORDINATE SYSTEM – there it should be set LOCAL

    And how do you set export parameters – as a GRID PLANE or ?
    0
    Comment actions Permalink
  • Avatar
    Florin Barbuceanu
    Hi Wishgranter,

    The model is not Georeferenced. I don't even know how to make a model georeferenced.

    The coordinate system is already local Euclidean.

    Image

    I export the model as GRID PLANE.

    Image
    0
    Comment actions Permalink
  • Avatar
    Wishgranter
    Hi Florin Barbuceanu
    Can you send me say 10k tris model for inspection ?

    As this sort of issues is related to georeferenced models used in "ordinary" applications.
    0
    Comment actions Permalink
  • Avatar
    Florin Barbuceanu
    In Unity it looks fine.
    0
    Comment actions Permalink
  • Avatar
    Florin Barbuceanu
    The same model simplified to a lower poly (1 milion) in Meshlab

    Image

    The same model simplified to a lower poly (1 milion) in Unreal 4.

    Image

    The artifacts in Unreal 4 are less pronounced but they are still there.
    This time I used the double 16 precision option in the export dialog.
    0
    Comment actions Permalink
  • Avatar
    Mike Simone

    Whoops, I was going to create a new post but I brought this one back to life, so I guess I will ask to to the question above.

     

    Was this problem ever addressed? I think my issue is slightly different but similar.

    Im curious on why every time I try to import a model into Unreal Engine, it always looks bumpy as heck and shiny but when I view the model in Modo, or RC everything looks great. (Im think it has to do with the assumed surface type and shadowing?)


    Curious if anyone has a good workflow for unreal.

    Type of file export? Settings on export? and how anyone is importing in Unreal and the settings on import.

    I may just give up and go straight to Unity if there are no problems there, but i feel like there is something I am missing with my knowledge of game engine and models.

     

    Thx!

    0
    Comment actions Permalink
  • Avatar
    Mike Simone

    Hi,

    I just want to comment on the right answer to this question that was asked years ago.

    In unreal engine, when you import your static mesh, make sure you check Use Full Precision UV in the static mesh editor for your model.

    There are pretty much three important steps.

    • Exporting from RC, you must include Normals or you will get jagged edges.
    • In Unreal, You must check Use Full Precision UVs.
    • You need to play around with the material details in unreal to add variables for roughness, specular and metallic. (So it doesnt look shiny)

    Cheers!

    0
    Comment actions Permalink
  • Avatar
    Aleksandr Gorky

    Thanks for this setting, Mike. I'm working with RC to UE4 transfer for last mounths). 

    And don't forget to check Export Vertex Normals: Yes when exporting FBX\OBJ from RC

     

    0
    Comment actions Permalink

Please sign in to leave a comment.