No ortho-projection possible!

Answered

Comments

6 comments

  • Avatar
    bisenberger

    Even though the Ortho Projection Tool indicated the Coordinate system as epsg:32636 - WGS 84 / UTM zone 36N, I open the Coordinate System dialog and scrolled down the list to epsg:32636 - WGS 84 / UTM zone 36N and selected it. When I did the coordinates for Centre updated to proper UTM coordinates. I rendered a new ortho and it exported correctly. This image shows the results of re-selecting the Coordinate system:

    You can see the coordinate read out for the cursor location on the ortho is also correct now.

    1
    Comment actions Permalink
  • Avatar
    Götz Echtenacher
    Hi ii3D,

    I never experienced this because I usually simplify significantly before texturing and creating orthophotos.
    But I did manage to create some from 700M+ models that were UNtextured.
    Does that work for you or does it also crash?
    It might help to pinpoint the bug...

    Best,
    Götz
    0
    Comment actions Permalink
  • Avatar
    bisenberger

    I'm lso having issues with exported orthos not being in the project coordinate system.

    RealityCapture version 1.0.2.3008 RC

    Here is an image showing the Application Settings coordinate system:

    this one shows the control point coordinate system (same as application settings):

    this one shows that the component is geo-referenced:

    This one shows the settings for the Ortho Projection Tool:

    In the help documentation is says to use top if exporting to GIS. I also created orthos using Map and Arbitrary and exported to compare world files. The world file is the same for all 3.

    This shows the export ortho projection options:

    I have tried with projected, global, and image. The results are the same.

    Here is the contents of the world file:

    0.0000000092
    -0.0000000000
    0.0000000000
    -0.0000000079
    0.6066855367
    0.5505352469

    I also exported a projection parameter files, here is the content of it:

    <OrthoProjection width="1932" height="2602" name="Ortho projection map" modelName="Model 5"
       modelGuid="{295E1024-5C58-4137-BD11-F4CC152C145B}" colorType="texturing"
       boxSideConerIndex="21" bEmpty="0" backFaceColorType="1" backFaceColor="2130706687"
       projectionType="3" bShowOrthoProjection="1">
      <Header magic="5787472" version="1"/>
    </OrthoProjection>
    <ReconstructionRegion globalCoordinateSystem="+proj=longlat +datum=WGS84 +no_defs" globalCoordinateSystemName="epsg:32636 - WGS 84 / UTM zone 36N"
       isGeoreferenced="1" isLatLon="1" yawPitchRoll="0 0 0">
      <widthHeightDepth>96.6555868889593 130.120300787686 14.9366197588348</widthHeightDepth>
      <Header magic="5395016" version="2"/>
      <CentreEuclid>
        <centre>0.606694346824674 0.550524940342791 85.3094461830333</centre>
      </CentreEuclid>
      <Residual R="1 0 0 0 1 0 0 0 1" t="0 0 0" s="1"/>
    </ReconstructionRegion>

     

    0
    Comment actions Permalink
  • Avatar
    bisenberger

    This image shows that the coordinate read out for the cursor location on the ortho has the same coordinates for the UTM projection as it does for the GPS coordinates:

     

     

    The UTM coordinates should be more like this: N3491092.692; E667175.913.

    As indicated by the GCP:

     

     

    0
    Comment actions Permalink
  • Avatar
    Zuzana Ďuríčková CR

    Hello ii3D,

    Please excuse our late answer.

    Are you still experiencing problems with exporting ortho-photos?

    0
    Comment actions Permalink
  • Avatar
    bisenberger

    It is pretty much working now. There is only one small issue. Sometimes the exported ortho is shifted slightly. This can be resolved by changing the pixel size and re-rendering and exporting the new ortho. There is more info on this towards the bottom of this thread:

     

    https://support.capturingreality.com/hc/en-us/community/posts/115000872531-ortho-export-not-project-coordinate-system 

    0
    Comment actions Permalink

Please sign in to leave a comment.