Basic workflow + problem with retopology and UV

Comments

14 comments

  • Avatar
    Götz Echtenacher

    Hi kozak,

    do you have any specific problem with RC in this workflow?

    Because to me it sounds more like a general question outside of RC and I could imagine that you will get more (and probably also better) answers in a different forum that is more related to your problem. E.g. I can't help you at all because I don't do any retopology and all that...

    0
    Comment actions Permalink
  • Avatar
    m.kozak.m

    Hello,
    thank you for your fast reaction;).
    Yes I agree. I don´t have any specific problem with RC. I just thought that here in this big community of people who are interested by photogrammetry I can find someone who will help me with this or give me any other tip or solution (workflow) how to get a perfect model out of reality and take it more under control..

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    No problem!  :-)

    When you say "under control" does that mean that you are not satisfied with thew model as it is?

    That might also be caused by a not optimal alignment...

    0
    Comment actions Permalink
  • Avatar
    m.kozak.m

    No, my alignment is great and I´m fully satisfied with model. I just have to work with those models in 3Dsmax, so I need low poly model, but I lose too much quality with decimation. Thats why I need perfect maps like a normals, diffuse and displace and I also need maps in bigger pieces not like on thousands pieces like a RC do:).

    I post a few picture, with
    Highpoly mesh
    30M high poly mesh
    low poly mesh with projected diffuse texture (the texture is blurry here)
    and diffuse map (there is also visible blurry texture)



    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Nice.

    Ah, I see what you mean. Did you do the low poly texturing in RC or did you use another software for decimation and reprojection of the texture?

    The scattered texture map has been criticized countless times but there is no solution at the moment...

    0
    Comment actions Permalink
  • Avatar
    m.kozak.m

    I firstly made a 500K poly model from 160Mtris by simplify tool in RC then I took this model to Zbrush and use Dynamesh and Zremesher (decimation to 10K poly). This low poly model was imported back to the RC and texture was reproject there. (UV was created in 3dsmax)

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hmm, I think there have been problems with imported UVs reported before.

    Did you try to create an unwrap (plus texture) in RC for the low poly model?

    0
    Comment actions Permalink
  • Avatar
    m.kozak.m

    But that step give me a texture broken on the thousand pieces or no? Still I will try it;). Thank you

    0
    Comment actions Permalink
  • Avatar
    m.kozak.m

    So I tried it and a result is too similar. Any pieces of model are still so blurry :/

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hmm. Did you create a new unwrap in the procedure? Could it be that your texture size is too small?

    The only other thing I can imagine is that with the super low poly model, the geometry on the recesses (where it is especially blurry) is too different from the original which would throw RC off when (re)projecting the texture...

    0
    Comment actions Permalink
  • Avatar
    chris

    do you have blurry textues on the high res model? if you do, its probably an alignment issue.

     

    if its only on your low res model. then you may need to adjust the large triangle removal threshold.

     

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    That's the one!  :-)

    The high res was fine...

    0
    Comment actions Permalink
  • Avatar
    m.kozak.m

    Hello, and thanks everyone;)

    Yes I tried make a new Unwrap and then reTexture but it looks similar. But generally I can´t do new Unwrap, because I need my personal UV for next editing in PS.

    Maybe I have any misunderstanding with reTextuing. So I tried work differently.
    1. test:
    I just imported Low poly model and directly go to button Texture. (photos more up shows the result)
    settings - fixed texel size
    select info panel says:
    texture quality 100%
    texture utilitization: 24%


    2. test:
    I imported model. Set texturing on maximal texture count. (texture count 8, resolution 16K) - selected all pictures
    result = blurry texture
    select info panel says:
    texture quality 100%
    texture utilitization: 24%

    3. test:
    imported model +Set texturing on maximal texture count. (texture count 16, resolution 16K) - selected all pictures
    result = blurry texture
    select info panel says:
    texture quality 100%
    texture utilitization: 24%

    4. test:
    imported model +Set texturing on maximal texture count. (texture count 8, resolution 16K) - selected just few photos with best look texture from the closest distance with most cover of format.
    result = better not to blurry texture, but any details of textures are missing. And corners of object are blurry
    select info panel says:
    texture quality 100%
    texture utilitization: 24%


    all pictures are sharp, shoot on canon EOS mark II or mark IV and too raw (then converted to tiff
    - should I have a choose only pictures with texture?

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi kozak,

    the texture quality only says how close your texel size is to RCs estimation of the optimal value - doesn't say how "good" it is. Utilization is simply how much of the texture file is used for the unwrap. It's weird though that you get the same result each and every time with different settings. I don't play around with those too much myself since it always seems to work out for ma.

    Have you tried chris' suggestion and raised the Large Triangle Removal value? It needs to be really high - it simply tells RC when to stop texturing large triangles (x times the average size I believe). So it can't really hurt anything apart from calculation time a bit.

    0
    Comment actions Permalink

Please sign in to leave a comment.