Texturing reimported 3D scans very blurry -> tolerancy settings?

Answered

Comments

10 comments

  • Avatar
    Götz Echtenacher

    Hi Sander Diels,

    could you post a wireframe screenshot of the decimated model? Maybe it's the notorious Large Triangle Removal Treshold?

    When you re-texture, do you also do another unwrap manually beforehand (in RC)?

    I really can't imagine it's the movement because a) it worked before and b) if it's really only milisecs, then it should be negligible.

    0
    Comment actions Permalink
  • Avatar
    Sander Diels

    Hello Götz,

     

    Please find attached a wireframe screenshot.

     

    I use Remake to unwrap in 4096x4096 or 8196x8196 depending on the end-application and I do not unwrap in RC.

    The mesh is around 350k faces but the process of the decimating amountand the Remake unwrapping has been used for a long time now (without problems before).

    Also I tested with another version which I didn't decimate (1,2mil faces) but the same result.

     

    So is it the Large Triangle Removal or something else?

     

     

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    Hello,

    something must have changed when you are getting different results now.

    Have you changed your equipment and/or anything in your workflows?

    In which software do you clean up your models? And is it still the same version as before the issues had started to occur?

    The preview quality does not have to be the problem, it depends what settings did you use for the preview quality, I can see you have changed the number a bit unreasonably: https://support.capturingreality.com/hc/en-us/community/posts/115001357172-High-model-normal-model

    0
    Comment actions Permalink
  • Avatar
    Kruzma

    Hello Sander Diels,

    It looks like you are using camera rig, so there shouldn't be problem in movement if your cameras are synced.

    Would you to send us screenshot of your UV map? e.g. in Meshalb you can go to Render ->  Show UV Tex Param. 

    0
    Comment actions Permalink
  • Avatar
    Sander Diels

    Hello Lubenko,

     

    We have changed to our installation yes but this should not be the problem as most scans come out perfectly fine after retexturing, I just noticed that more scans are coming out blurry.

    Also if I test this in another software program but not RC this problem doesn't happen.

    So I repeat that I think that RC is not being as tolerant as other software applications should there be slight movement between 2 sets.

    It could be that our previous installation took the pictures a bit faster as the one does now (we are investigating this) and this could be that RC is more sensitives for minor chanes in movement, is this possible?

     

    And if it is possible, are these settings I can change in RC, to make the program more tolerant for moving photosets?

    This would seem to be a good solution to solve these bad retextured scans by changing the settings for those particular scans and reset to the original once done.

    Is this possible?

     

    For the rest I didn't change anything in workflow, programs and there haven't been any updates.

    I am quite convinced it is a timing/movement problem from scanning followed by an intolerancy problem by RC (too strict calculations).

     

    Hi Kruzma,

    We are currently checking how well the camera's are synced.

     

    I don't think the UV is the problem.

    Scans with same workflow don't cause problems and the workflow hasn't changed for a long time.

    In attachment a screenshot.

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Sander,

    sorry, I only got notice of your answer just now. I'm pretty certain I looked at the thread in the last couple of days and it wasn't there. Weird. Was it pending approval? Anyway...

    Since your mesh is very uniform, I think we can rule the Large Triangles out.

    Does the blurry texture appear only on the re-imported mesh?

    And how does it look like if you do an fresh unwrap within RC on the resurfaced mesh?

    That's just to narrow down the error.

    Or did you solve it in the meantime?

    0
    Comment actions Permalink
  • Avatar
    Sander Diels

    Hello Götz,

     

    The unwrap in RC doesn't help.

     

    The blurry texture appears due to movement in both sets so I am asking RC if there is a setting to be less "strict" in this ruleset.

     

    As stated before if I do the same test in another 3D scan software the endresult remains sharp texture while in RC it doesn't.

    For me that means that RC is not tolerant enough for the projects I've recently done and I would like to know if RC can change settings to accomodate my needs.

     

    Looking forward to an answer.

     

    Kind Regards,

    Sander

     

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Sander,

    so the blurriness occurs only with the second image set, did I understand that correctly?

    Can you quantify the movement that you observe? Is it 1 or 2 pixels or more?

    The thing is that there are similar cases with blurry textures (I believe also on re-imported meshes with an external unwrap) that show similar errors but without changing the images set, so I am not sure it the movement is the real cause here.

    Did you play around with the Coloring Method or Style?

    I gather from your screenshot, that you use only one texture map, right? What's the resolution? It might be worth a try to use a really low one (2-8k) just to see if that makes a difference. There might have been a case where that played a role, but I am not 100% certain...

     

    0
    Comment actions Permalink
  • Avatar
    Sander Diels

    Hey Götz,

     

    If we would want to put it in pixels I would say it is more. (imagine a person leaning forward, breathing heavy or shaking his head a bit in between the 2 sets).

    I will test the coloring method.

     

    I'm pretty sure the problem originates from movement betwee 2 photosets.

    Change in resolution doesn't help or change anything.

     

    Is it possible to answer the question if there are any settings in RC to help this as I asked before?

    Thank you!

     

    Sander

     

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hey Sander,

    sorry that I didn't explicitly answer the question. Believe me, if I knew it, I would have told you in my first post!  :-)

    Actually, I am pretty certain that there is no such thing as you ask for.

    Another idea: have you tried to start everything from scratch? If it isn't all too time-consuming, it might be worthwhile since it could point towards a file corruption, which is also possible and not uncommon.

    0
    Comment actions Permalink

Please sign in to leave a comment.