Reconstruction in Normal Detail taking too much time

Comments

7 comments

  • Avatar
    ShadowTail

    There is a multitude of reasons for this behavior.

    Did you set a reconstruction area to limit how much work RC has to do?

    Is the cache filling up your disk?

    Is RC using up all your RAM and has to resort to using the swap file? It would explain the unresponsiveness.

    16Gb RAM may be a little on the low side for 1600+ image projects.

    0
    Comment actions Permalink
  • Avatar
    filipe.bg

    Hi ShadowTail,

     

    Yes the reconstruction area is set. I still have 650Gb free on the HDD where cache is located.

    Just checked and RC is taking 5Gb of RAM (no other applicaions running).

    Right now it's not irresponsive. I'm trying a second time, already 6 hours in and it's getting slower and slower.

    Should I try reducing the Maximal vertices count per part? Does it make sense?

     

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Filipe,

    The estimation is never accurate, it can be twice the time or several times as long. Depends on the image set and the quality of alignemnt and more.

    The quickest way to narrow it down is to create a new file, align again and do another reconstruction.

    0
    Comment actions Permalink
  • Avatar
    filipe.bg

    Hi Götz,

    That's really annoying, not having an idea when it will be finished. I'm having this problem with large scenes. I simply have no idea if it's going to take 10 hours or two weeks...

    Could you explain how creating a new file and aligning again could help on this?

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Filipe,

    I feel with you, it is awful not to know.

    In my experience (no data, mere gut-feeling), it can take up to 3 times (or so) as long as initially displayed. There is no general rule because it depends on the dataset. Usually, I would say it's about twice as long.

    I am quite confident to say that 10 times the original estimate is too much. Similar things have been reported and also remedied by starting from scratch. It could be that in certain constellations RC kind of gets stuck due to some mathematical peculiarities in the model, which are not supposed to be like that. Sorry for being so vague, but I am a user and not a software engineer. Another possibility is that the file got corrupt. In any case, I myself have used this "method" a few times and it worked for others, too.

     

    0
    Comment actions Permalink
  • Avatar
    filipe.bg

    Thanks Götz. Other users experiences are very valuable, even if the solutions are "gut feeling". It's better than nothing that's for sure.

    I will try that on future scenes. As for the big scene I was trying to process I had to give up, unfortunately.

     

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    No problem!  :-)

    You mean you canceled? That was probably the only option anyway. Now you can start fresh, if you still want...

    0
    Comment actions Permalink

Please sign in to leave a comment.