PROMO license - not being able to activate it




  • Avatar
    Rafa CR

    There is only one version of RC, that you can download from our website. After download and installation you have to activate it. To do so you have to enter you email and password that you used for account creation on our website.

    Then on the next screen you should be able to chose your promo licence.

    Comment actions Permalink
  • Avatar
    Emil Danut Mihaila


    So everything is solved but I ll take the time to sort of quickly go through why I had this issue, just in case someone else bumps into the same situation:

    First, the demo/released versions. 
    As stated above, they are the same so while you will find forum threads from 2 or 3 years ago saying there are several versions, as Rafa said, there aren't! 

    The activation: 
    The main reason for which I had the issue to begin with was because the ''Settings'' button behaved... weird. To be more specific, when I would click it, it would open the help page corresponding to the ''Settings'' menu. 
    Weather it did open the menu somewhere or not... I m not sure.. But I looked everywhere and changed all the layouts and I just couldn't see it. 
    The solution:
    The way I found it was by opening a project I had around on my computer, and then tried to press the button again. 
    This time a small bar poped open at the bottom of the 2Ds viewport (where your photos are displayed) that I could expand. 
    Here, you can find the above mentioned section for Licenses and ''Change the application owner''. 
    It will take you to a dialogue that asks you to login and then you will be able to chose your license from a pull down menu.

    I hope this will help someone down the road but I decided to post the whole thing since on facebook there were several people also who mentioned they had simmilar issues.

    Thank you for the help, Rafa!


    Comment actions Permalink
  • Avatar

    Thank you for sharing the resolution. Unfortunately I've no idea where the settings button is, the ones I see, as always, only open the option for alignment/reconstruction.

    In my case I had activated the PPI licensing, then found out that it does not work for my workflow (I posted a bug message yesterday, no answer yet), THEN bought a PROMO license for the last time.

    To my surprise it was impossible to activate it, RC would just start off the PPI and I did not find any licence manager, within the application, to change it.

    Uninstalling and reinstalling RC was not sufficient, I had to purge the registry before I was able to give again my credentials and activate the promo.

    This is somewhat disappointing, RC is a very fine application but I really don't understand why they make a point to render the life difficult to their customers. They really do their best, never seen a commercial app with such a clumsy protection scheme (before) and with such a nonexisting licence manager (now).

    Comment actions Permalink

Please sign in to leave a comment.