Curved model after Reconstruction. Help

Comments

14 comments

  • Avatar
    jasper

    The curvature you are seeing is due to consecutive errors of the camera alignment due to wrong camera and lens distortion parameters. Which camera did you use and which distortion model (brown 3, brown 4 etc) did you choose for alignment?

    0
    Comment actions Permalink
  • Avatar
    Krasimir

    I don't know what those mean. I have taken the images through my phone. I made a video and extracted every second frame to make up the images for my mesh. The camera has been on the same height for the entire video.

    0
    Comment actions Permalink
  • Avatar
    Sam from sample & hold

    Interestingly we've recently had a similar issue.  I'm going to be doing some testing tomorrow as I suspect our issue is down to Automatic Distortion correction but want to be sure.

    Interesting to note Jasper that you allude to changing the Distortion Model prams.  I will take this in to account tomorrow.

    Cheers

    0
    Comment actions Permalink
  • Avatar
    Krasimir

    Let me know how it goes ! if  you find anything causing this. I personally couldn't.

    0
    Comment actions Permalink
  • Avatar
    Sam from sample & hold

    So I've run quite a few tests and I'm coming to the expensive conclusion that the Nikon z7 doesn't work with reality capture.

    I've tested all the distortion models using the 24-70mm lens.  I've noticed that at 24-35 i don't seem get as much of an issue but at 50-70mm it goes very wrong.  I've tested using the RAW's, JPEGs and DNGs processed through capture one setting the lens profiles to Generic.  I've tested stripping the RAWs of the exif data.  I get better results using the division distortion model but not much better.

    I've tested using an 85mm lens on the z7.  the results are much better however they are still not good, you can see the difference between a z7 (with 85mm lens) and d800e (same lens) below, the z7 is Grey and bens upwards at each end.

    I can not figure out why there is an issue.  I have turned off everyting in the camera including vibration compensation so if anyone has any thoughts I'd really apprecaite some advise or we have a £3000 brick on our desk!

    Cheers,

    Sam

    p.s just for reference the distance between the holes is around 50mm so all in this object is around 750mm in length.

    0
    Comment actions Permalink
  • Avatar
    Sam from sample & hold

    Hi again,

    So I've not managed to get my hands on a Sony A7R IV and an seeing exactly the same issues as the z7?

    I know this is possibly going of topic, but I'm starting to wonder if this is a mirrorless issue?  Krasimir I'm assuming your camera is mirrorless?

    Cheers

    Sam

    0
    Comment actions Permalink
  • Avatar
    Krasimir

    Hey Sam

    Im not sure what being mirrorless means...
    Im using the camera of my s10

    0
    Comment actions Permalink
  • Avatar
    jasper

    Would either one of you two be able to share some of your problematic data sets? I'd like to try it for myself and report back the findings.

    0
    Comment actions Permalink
  • Avatar
    Sam from sample & hold

    Hey Jasper ,

    I'll wrap up the data and send a link.

    Cheers

    0
    Comment actions Permalink
  • Avatar
    Krasimir

    Jasper, you mean the log files that come in a folder after you export the mesh ?
    Or do you mean another data set i'm not aware of.

    0
    Comment actions Permalink
  • Avatar
    Sam from sample & hold

    Just so you know, I've sent a message with a link but its not been approved yet.

     

    0
    Comment actions Permalink
  • Avatar
    Jasper Mink

    Hi Krasimir, I specifically meant the original images (all 350 or a part of it) so I can process them as well to see where your issues arises and why it's happening. @Sam thanks for the email!

    0
    Comment actions Permalink
  • Avatar
    Krasimir

    Ah right. I'll put them up somewhere and send a link. Do you prefer here or somewhere else ?

    0
    Comment actions Permalink
  • Avatar
    Krasimir

    Apologies for the delay. 

    https://1drv.ms/u/s!Apui-L8jHg8unQqTVhaVlEBCt0yZ?e=gJlGJs

    These are all the images i've used in that scene.

    Let me know how your results compare to mine.

    0
    Comment actions Permalink

Please sign in to leave a comment.