Reconstruction works in Normal Detail but loses areas in High Detail

Comments

22 comments

  • Avatar
    Rafa CR

    Hello. 
    do you use reconstruction region? 

    Was there any error message after compledted reconstcution process? 

     

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    I use reconstruction regions (Is there a way not to?), I just removed the region after meshing for the screenshots in the first post. There is plenty of plenty of space around the model though, I even made a second attempt with larger bounding box sizes.
    No errors, at least none popping up, is there a log somewhere?

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Ok, I deleted my models and made a new normal detail and high detail. First the normal one, that worked as expected ("model 2"), then the high detail one ("model 1") with the same results. No error messages. I've attached a screenshot of some of the settings (should be default) and one of the console window I found.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Different object, same problem.

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Could you please try to shift and double click on the RC icon on desktop and select Reset the application settings and then once again and make it like a clean install? This should not be happening at all and we're not aware of such issue, so I believe this could help. Also, make sure you have the latest version of RC, 10403 currently.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Ok, I did reset the settings before but not the additional "clean install option". So I did both again, made a new file with the fox, and ran the steps as before. It looks slightly better (a bit less of the ears missing), but it's still happening.
    The version I have is 10403 (Steam).

    I've taken the liberty to upload the fox scene for debugging (please let me know if it makes sense to upload the other one as well, since it's arguably worse. I just haven't retried with that one yet). You might notice I'm a bit in a hurry :D

    https://drive.google.com/file/d/1iGnbVhBFxGOUfMdH3rs9RfF-Bvv01MyM/view?usp=sharing

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Ok, here's the other one. The "normal detail" got a bit worse at the top and for the "high detail", the stand at the bottom a tiny bit better. Still not really usable in this state.

    https://drive.google.com/file/d/1S6WNSOcIz38UECt3zFN_HStTTdJAbIsB/view?usp=sharing 

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Are the files in the links containing the whole dataset? I would need that. (all of the images) I would recreate the project.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Yes, the first link contains the fox, the second link contains the spinning toy thing. Both links contain the full images set (about 75 images each) and the project files for each.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Sorry to be a bit pushy about it but I'm having tons of scanning work lined up and am running out of time. Has there been any progress or findings regarding this matter?

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Hello racoonartworks I would say this is being caused by the black background (mask I suppose). Do you have access to an unedited image of this with the former background? If yes please try that instead. The separation of the background and foreground is not the best in this case as it is black to black when speaking of the ears for example.

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Even a better exposure of the shadowy areas on the subject could get you to better results. 

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Erik Kubiňan CR The images are unaltered photos. There is no masking happening. The only thing I did is putting them through my raw decoder. There's a black paper backdrop, and the model lit with a ringlight, that's why it looks like it has been masked. I even made a second photo series (sharper) with a slightly altered raw processing process and I can still not get the ears. It also doesn't explain why "normal detail" works and "high detail" suddenly freaks out. Imho there is also still some value contrast between ears and the background. I have some other models that quite frankly look much much worse and those at least produced a mesh. Besides, the spinning top thing, due to the fact that it's wood, has more than enough value differentiation and still doesn't work. The issues also only happen at the top and the bottom ends.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Just to underline my argument. This is an image of a "clean" series I made. The ears and arms are basically black. And yet RC somehow managed to get something out of it.
    In comparison, that's an image of the ears in the sequence I sent you (which totally missed the ears). There's plenty of small noisy detail on it for RC to pick up (which also worked very well on the other black parts of the model).

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Would you have some space to shoot the fox without any backdrop once and try it? I get your point but this is the first time I have seen such behaviour and this yet is my only guess. So if you can, shoot it without a backdrop this time and with a stronger light/bump up shadows and exposure in the post.

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Meanwhile I am trying some different alignment settings to try and get more out of it. 

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    If I shoot without a backdrop, it probably won't work at all, since it's a moving turntable with stationary camera. More light also is a bit of a problem since I'm already at maximum light intensity with quite long shutter speeds due to my high F-stop. I can try to boost the blacks in my raw converter and try that but this won't solve the issue with the wooden model as it's already bright.

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    I have adjusted the alignment settings as seen on the picture below and you can already see some improvement in the high detail reconstruction. What this means is:
    The area is too dark and gets close to what the backdrop is
    The area also has not the best features on it which are hard to detect
    To answer beforehand to a question you would ask (why does normal detail work better then?) It may be due to this: The normal detail lowers the resolution of the images before reconstructing and the pixels defining the tiny dust detail could then come together creating something more likely to be recognised as a pattern. 

    Solution is to convert the RAW files better by increasing the shadows, decreasing highlights,sharpening, clarity or texture adjustments. Or simply adding some fake detail onto the surface of your scanned object. (coating spray, mud, flour) and doing two sets of images. One clean and one "dirty".
    I also recommend going for some other backdrop instead.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Thank you very much for the effort Erik!
    I made a brighter version (just with raw processing) and it significantly improved the result. Still not great but more usable. I'll try your settings next and see if that helps. I see your point and understand the explanation but I'm also not totally convinced, mostly due to what happens in the wood model and other areas that work well. I will do more testing and see if I can come up with something.
    What I find interesting is that sharpening/clarity is something that is suggested to be used. I always thought less is more when it comes to processing images.

    I'm already shooting two versions, one for geo, one for texture, this is one of the earlier tests. In the meantime I was able to improve the results with different powders (yet the ears kept being a problem).

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Well good luck then, keep me updated whether everything works fine. Sharpening and clarity would not normally be too recommended, but in a case like this one, it may be useful.

    0
    Comment actions Permalink
  • Avatar
    racoonartworks

    Ok, just as a little "post mortem" feedback: I managed to make it all work in the end. I changed a few details in the powder mixture and went for different alignment settings that worked better with some of the models. Not sure what the initial problems were but I think the lighting gradient on those thin areas are to harsh for RC to pick up properly. So the thinner the geometry, the tighter the curve is and it's less likely to go through.
    Either way, I think I have it under control now. Thanks for the support Erik!

    0
    Comment actions Permalink
  • Avatar
    Erik Kubiňan CR

    Pleasure is mine Sir, glad you got it fixed.

    0
    Comment actions Permalink

Please sign in to leave a comment.