Running out of video ram

Answered

Comments

8 comments

  • Avatar
    tingelbobber

    I had exactly the same Problem. The documentation about the cliping box is very confusion, also not complete, i think.

    If i remember right, you have to select the component, then go to the Scene Tab, then at the most right, there is a Button Clipping Box. 

    Also, the message only tells you there are to many tris to display, you can still export it and view it in another tool, like Meshlab. But such high res meshes are really no fun to work with. Try to reduce the tri count with pressing on "Simplyfy". There you can specify a target tri count. In most cases going from 40 mio tris to 20 does not make a significant difference in quality and detail.

     

    Pro Tip: Clicking and reading around the Help in RC while your reconstruction process is in progress is always a good idea:) Learned a lot.

    1
    Comment actions Permalink
  • Avatar
    Phil Nolan

    Thanks I was just starting to come to the conclusion that the model was there just not displaying. I guess I was right.I'lll look into this clipping box, I guess I misunderstood what it was.

     

    BTW 3D-Coat has no problem with 40m tris.

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    The display limitation concerns the Sweet setting only, right?

    So there should still be something on the displays.

    How many polys/tris did your models have?

    0
    Comment actions Permalink
  • Avatar
    Phil Nolan

    I'll have to look around, I haven't seen a setting called Sweet. The building model is a little over 50m tris.

    0
    Comment actions Permalink
  • Avatar
    Zuzana Ďuríčková CR

    Hello Phil,

    Sweet mode is on of the three rendering modes available in the 3D SCENE context tab. 

    Rendering in Solid and Sweet mode is limited to 40M triangles. It is the maximum size of the mesh that is possible to display in those two modes. It is possible to display 40M triangles only for the GPUs with the 6+GB VRAM (video memory). Other restrictions are as follows:

    RealityCapture Help

    • 8 million triangles for 1GB VRAM,
    • 16 million triangles for 2GB VRAM,
    • 31 million triangles for 4GB VRAM,
    • 40 million triangles for 6+GB VRAM.

    If you wish to display models larger than 40M in Solid or Sweet mode, it is possible only by parts using Clipping box as mentioned in the previous comments. Clipping box does not change the created model in any way, it only limits the part of the model for displaying in 3D view.

    There is also a video in the application Help, section Clipping box with the illustration how to create and edit clipping box. 

     

    0
    Comment actions Permalink
  • Avatar
    Phil Nolan

    Great thanks, I hadn't noticed that there before.

    0
    Comment actions Permalink
  • Avatar
    mark ruff

    Would 2 x GPU's solve this?

    0
    Comment actions Permalink
  • Avatar
    jasper

    Hi Mark,

     

    In my experience it does not. But it's just a visual thing . If you use 'Render' it will export a 16k screenshot of your model in full fidelity.

    0
    Comment actions Permalink

Please sign in to leave a comment.