RealityCapture Assistant or second screen connectivity issues.

Comments

6 comments

  • Avatar
    Wallace Wainhouse CR

    Hi Bjorn,

              Apologies for the long and complex response, we are currently working on improving this.

    1. Checking the connectivity - in order to make sure your second device is on the same network as your RealityCapture host, you can use 'ping' command from cmd, while specifying IPv4 address of the secondary device. You can usually obtain the address from the connection details in network settings of your mobile device.

    2. Checking the firewall - first in order to verify that the service handling the connections is listening, we can open Resource Monitor windows utility. In the Network tab we will find 'Listening Ports' category. If we sort by Port number, we should find RCNode.exe listening on the port (default is 8000) for incoming TCP connections. Last column showing the Firewall Status should read 'Allowed, not restricted'.

      If you find a problem during this step, causes could include some other service running at the same port, blocking RCNode.exe from listening. Common pitfall with firewall configuration is that firewall has to be allowed for the network profile (public, private or domain) of the network connection we are using between devices.
    1. Checking the configuration - RCNode tries to determine correct IPv4 address for creation of HTTP URL that the second device connects to. It is possible that with multiple network adapters (WiFi, Ethernet, etc.) this address is not correctly determined. When you scan the QR code, you will see the IPv4 address in the URL. Check with the host configuration that the address used is the address of the adapter on the same network as the IPv4 address of the secondary device (for Local Area Networks, they will usually start with the same three numbers).

      If they do not match, first make sure to exit RCNode.exe from the service tray and close the pairing dialogue. Then locate the RCNode.exe in your installation directory (the default is C:\Program Files\Capturing Reality\RealityCapture), and then start RCNode.exe from the command line with parameter -hostAddress a.b.c.d (a.b.c.d specifying your IPv4 address to use). You should then see the correct address when you try to connect from the secondary device.
    0
    Comment actions Permalink
  • Avatar
    Björn Syse

    Hi, thanks for a quick answer! 

    1. Yes, they definitely on the same network. I can ping my iPhone from my computer.

    The phone is at 192.168.1.158

    The computer is at 192.168.1.76 with only one network adapter actually being active. So there should be no confusion there. 

    2. Interesting yes, RCNode seems to be listening and is allowed. Nothing else is using the port as it seems? 

    3. If I look at the url generated when using the QR code, the IP is correct. The rest of the string is like this: 

    192.168.1.76:8000/static/secondscreen/secondscreen.html?authToken=3C04F1DA-021E-47A8-8C2...

    But it never loads. If I enter just 192.168.1.76:8000 from a browser on the computer, I get this message :

    {"message":"Missing authentication token.","code":-2113863678}

    However, If I try the same thing from the phone, the server never loads. Browser is stuck on loading and then finally gives up. I guess that is some sort of indication of something, but I'm not sure what. 

     

     

    0
    Comment actions Permalink
  • Avatar
    Jan Spisiak

    Hi Björn,

    Sorry for the issues, we are working on improving our solution for better user experience. In the meantime, here are few things that we can try. You can try the SecondScreen application from your PC to make sure this is not a software issue.

    To open the SecondScreen application from the PC, first click on the QR code in the pairing dialogue. This will open IE11 (this is fixed in future versions, and will open the default browser), from there you can copy paste the URL to your browser (chrome, firefox or edge). You should then be able to see the empty project ( or the project you have opened ).
    If this works, then the issue lies in the network configuration. Check if you don't have AntiVirus with firewall capabilities that could block the incoming connections. It could also be the case that your router for some reason blocks or reroutes certain ports on the local network. This can be checked in your router administrating page, usually under port forwarding settings. It could also help to set forwarding from the iPhone to the PC. Does the browser provide any error information, why it is not opening http connection?
    Thank you, best regards
    Jan
    0
    Comment actions Permalink
  • Avatar
    Björn Syse

    Hi, test #1 works. I can access the scene from the same computer. So network seems to be the issue here.

    No port forwarding rules for those ports or ip in my router, that shouldn't be the issue. 

    Safari on mobile gives no error, but chrome on iphone gives me the server timeout error (ERR_CONNECTION_TIMED_OUT) after a while. I've tried it on my macbook on the local network aswell with same error. 

    I do have Symantec End-point protection, but as far as I can see, the firewall capabilities of it is not enabled. 

    0
    Comment actions Permalink
  • Avatar
    Jan Spisiak

    Hi Björn,

    In this case we really are hitting a network issue. If it is timeout, then it's likelier that there is something blocking the connection (but the devices can see each other on the network). I don't have experience with AntiVirus solutions so I can't help with that, but to check that the Windows FireWall is not an issue, for some unknown reason, you can check this.

    1. Open Windows Defender Firewall with Advanced Security
    2. Open Windows Defender Firewall Properties
    3. Open Profile for your local network connection (in my case Private, make sure that it's the one you use)
    4. Under Logging, click Customize
    5. Change Log dropped packets to yes and click OK
    6. Under Monitoring you will see your active connection profile with clickable log file name link

    With this setup, once you've tried to connect from different device, make sure that the file does not contain any lines such as:

    2021-02-19 09:08:37 DROP TCP 192.168.0.122 192.168.0.74 48571 8000 60 S 874913268 0 65535 - - - RECEIVE

    The important part is that this would mean that the firewall is still for some reason blocking the port number 8000 for incoming connections. Unfortunately this kind of problem is hard to diagnose from our side. Thank you for understanding.

    Best regards,

    Jan

    0
    Comment actions Permalink
  • Avatar
    Björn Syse

    Hi Jan, thanks again for your detailed support. I've followed the steps, activated loggin (in my case, it was the public profile that was active) , and then retried connecting and checked the logs. However, they do not report any blocking but only these lines: 

    #Version: 1.5
    #Software: Microsoft Windows Firewall
    #Time Format: Local
    #Fields: date time action protocol src-ip dst-ip src-port dst-port size tcpflags tcpsyn tcpack tcpwin icmptype icmpcode info path

    I understand it's hard to troubleshoot, I've allready received more support than I would have hope for though, so thanks for that. 

    0
    Comment actions Permalink

Please sign in to leave a comment.