Drone imagery orientation

Answered

Comments

10 comments

  • Avatar
    Götz Echtenacher

    Hi James,

    the first thing that comes to mind is that the GPS info interferes with the coordinate system of the laser scan data.

    Try Workflow - Application - Settings: Ignore GPS Exif = True

    0
    Comment actions Permalink
  • Avatar
    James Brennan

    I have changed that and then reimported the imagery and it has moved but still is weirdly oriented.

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hmm...

    Does is say in the alignment report (bottom left when selecting a component) that it's geo-referenced?

    Something just strikes me: Where are the scanner cubes in the model? Is it possible that you get separate components because the images won't align with the scans?

    0
    Comment actions Permalink
  • Avatar
    James Brennan

    Looks like you are right. It has made 2 components. One with the scan data in and one flipped one with the imagery in! For the alignment it does say its georeferenced.

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Ah, bad news!

    You could try playing with the settings a bit but that's probably futile.

    The trick is to treat the scanner like a camera, because hat's how RC processes it.

    So you will need to "connect" some of the scanner positions with drone images according to the rules of photogrammetry...

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    Hello James 
    Please clean cache, then try again with the completely new project in RC, only with drone photos in the begging. 
    If this happen again please or try again switching off GPS information as Götz mentioned before or you can set in Alignment settings camera priors to - False. If this fails you can adjust ground plain manually.
    Does your laser scan align with the drone images?

    0
    Comment actions Permalink
  • Avatar
    James Brennan

    Thanks. I will have a go at doing that. There used to be a tutorial on aligning laser scan data with imagery on this web site I will see if I can see it. Out of the office now so will have another go on Monday. Thanks for both of your help.

     

    0
    Comment actions Permalink
  • Avatar
    James Brennan

    Got it sorted. Imported the ground control first in a new project then added in images gradually with lots of saving. Now having a problem with texturing it! Anyone got any ideas? It comes up with a warning to increase the maximal texture count.

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    This message means that unwrap cannot be created with the current settings. This happens when you have a large model and you use e.g. the default unwrap parameters while the unwrapping style is set to Maximal textures count and the textures count is set to 1. In this case RealityCapture (RC) cannot fit the whole texture into one. Please change the default unwrap parameters in the RECONSTRUCTION tab – Settings – Coloring/Texturing, or use the Unwrap tool (located in the RECONSTRUCTION tab) with different unwrap parameters. You can, for example, change the unwrapping style to Fixed texel size so that RC creates as many textures as needed according to the other parameters. Alternatively, as stated in the error message, you can preserve the unwrapping style and raise the maximum number of textures or their resolution.

    0
    Comment actions Permalink
  • Avatar
    James Brennan

    Many thanks. Finally got there!

     

    0
    Comment actions Permalink

Please sign in to leave a comment.