Ground Control Point Weirdness

Answered

Comments

10 comments

  • Avatar
    Rafa CR

    Hi Tim

    Please clean cache and then realign once again the photos with the GCP or try once again but switch of the GPS information in Exif at first alignment. Please check as well your GCP data, and make sure that you set correct coordinates

    0
    Comment actions Permalink
  • Avatar
    Tim B

    Ah, of course. Thanks, Rafa.

    Clearing cache seems to have helped. 

    0
    Comment actions Permalink
  • Avatar
    Tim B

    So clearing the cache made things slightly better, but not by much. 

    New flow:

    • New project, clear cache
    • Import GCPs
    • Set "Ignore GPS Exif = True" in RC settings
    • Import images 
    • Place the GCPs on appropriate images
    • Align 
    • Component is still tilted. Looks like this: 
    • Control point info looks like this: 

    Looks like Southwest and Northwest are offset in the 3D view and have a large error. 

    Any suggestions? 

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    In your first example Northeast and Northwest GCP show errors, now it's Southwest and Northwest. 
    Please check your control points. What coordinate system do you use? 

    0
    Comment actions Permalink
  • Avatar
    belushyhojo

    I have the same issue

    the GCP are accurat and even if there is jsut ONE the model tilts

    any clue
    __________


    UPDATE:
    i created everthing new in a new file ignoring GPS from images and it worked out perfectly

    BUT it is a pitty that in need to put everthing into trash to ajust the orientation to GCP....

    maybe this could be a bit easier and not through timecunsuming recalculations

    UPDATE 2:

    Errors again!!

    After adding additionals points after i created the allingment it breaks everthing

    this is such a pitty

     

     

    1
    Comment actions Permalink
  • Avatar
    Tim B

    Rafa,

    The control points should be good. Also, checking the map shows them in the same position as before:

    The errors and offsets seem to show up randomly every time I start over.

    Coordinate system is epsg:4326 - GPS (WGS 84)

     

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    Tim, 

    Please could you paste here print screen or send through the contact from on our website, coordinates of your all control points that you are using in the project (Long,Lat, Alt) 

    0
    Comment actions Permalink
  • Avatar
    Tim B

    Rafa,

    I sent an email with the control point data through a "Contact" form on your website. 

    Please let me know if you've received it.

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    Hello Tim,

    Yes, mail well received, thank you. 
    Would be possible for you to share with us all data for this project that we could reproduce scenario and see what else can be the issue in this particular case?

    We will need project file with extension *.rcproj and project folder with all *.dat files, as well original photographs and GCP. 

    0
    Comment actions Permalink
  • Avatar
    Tim B

    Rafa,

    I've replied with the share links for the data requested.

    Please let me know if you've received it.

    Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.