Opening the saved project doesn't give the exact model back.

Answered

Comments

25 comments

  • Avatar
    Rafa CR

    Hello, 

    You can change views by clicking on 3d window and then click on the SCENE button in context ribbon. And in scene render you can switch between different modes: Vertices / Solid / Sweet. 

    You can read more in application help in the topic - Real-time Scene Renderer

     

    1
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    Thanks a lot. That worked. Can we export the texture/material as a separate jpg file in RC?

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    Yes, when your model is textured in export chose Mesh  - then in save as type chose just texture option. 

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    But it gives a rcinfo extension , can't it be changed to jpg format?

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    rcinfo is just info file. it is xml file that contains model coordinates. 

    If you want to export texture only then in export chose Model and  then as in the attached images: 

     

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    The problem is it works fine if I start reconstruction and export it all together. But if I save my reconstructed project, and the open it, as discussed earlier change the Mesh renderer to sweet, what happens is I dont get the Texture settings while exporting. Then I have to hit texture again and then I am able to export it successfully. What should be done to avoid re-computation of Texture?

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    you have to first texture your component to see textured mesh in Sweet mode. 

    Are you sure that when you open your project you have selected component that is textured ? 

     

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    I saved it after texturing components. I am attaching screenshots. My images show Tx sign which means textured as far as I know. You can have a look and suggest proper method.

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    Tx next to the image means that image is being used in the process of texturing. 

    But you models do not have texture. 

    This should look like that :

    If you click on the model you can see report there you will see information if your model was textured too. 

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    I always save the textured model. I don't know why I cant find the texture after re-opening saved project.

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    But did you actually made texture? As it seems that you colorized your model instead. If so, then your mesh will have only vertex  colors and this cannot be exported as texture. 

    What version of RC do you use ? 

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    Yes , I textured it. Did it again and saved , same thing happened while re opening. For some reason texture goes away only coloured mesh remains. I use 1.0.3.6310 RC

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    if you simplify a model, you need to retexture it again (please have a look at the short tutorial 'Simplify' in the help section of the software); also you need to select the proper model in the 1Ds panel for further processing, including display

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    I Know that simplifying will remove texture but the main thing is I hadn't simplified it.

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    could you please move the middle and possibly also the right line of the 1Ds panel (middle one to the left and right one to the right) so that we can see the full information that is currently cut in your screenshots, and post a screenshot of just this 1Ds window?

    0
    Comment actions Permalink
  • Avatar
    Rafa CR

    Would be possible for you to share with us all project files and the images? 

    If yes you can send link with the files directly to us through contact form on our website https://www.capturingreality.com/Contact

    Thank you 

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    I am attaching the screenshot.

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    so Model 6 onwards is not textured, because there is no Tx sign in the middle

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    Hi, Rafa ! I am a researcher and CEO of an IT firm. I don't think currently I can share the project files. I would specially appreciate RC community to have developed a wonderful software. I tested it to set benchmarks against other photogrammetry software , was quite impressive I must say. 

    I would surely try to send my project files.

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    Yes Lucia every time I close my project texture of model 6 onwards disappears

     

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    I thing I get it, I may be wrong, but it is a filtered model. Perhaps filtering has such effects. Is it advisable to delete all other models not in use? Will that fix the saving of texture part?

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    no, filtering keeps the texture if it had been fully computed before filtration,

    but deleting the models you do not want/need to keep is certainly advisable if there are too much of them to handle

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    Okay I will definitely try to fix the save problem. Thank You.

    0
    Comment actions Permalink
  • Avatar
    Jyoti Prakash Sahoo

    I got these directional light rays, would like to know more about it, if we can disable it. And also my right click move control is now constrained , it is zooming in instead of moving around the mesh.

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    hello, the orange lines are mentioned in this help tutorial: Geo-reference the Scene (Geo-referencing a Model),

    to turn them on/off, tick Residuals in the 3D SCENE context tab:

     

    0
    Comment actions Permalink

Please sign in to leave a comment.