What is the best way to take out trees?

Answered

Comments

7 comments

  • Avatar
    Götz Echtenacher

    Hi Pjotr,

    I don't think there is an easy one-button solution for this.

    Recently I found out that the reason for holes not being filled in happens only when there are tiny holes on the margin that meet with the main hole in one vertex. Or phrased the other way around if the margin of a hole meets itself in one point. Does that make sense?

    Ah, never mind, here's an illustration:

    So basically you need to find this spot and break it open, then filling it should work. I haven't done it very often, but it never took very long to find the culprit...

    0
    Comment actions Permalink
  • Avatar
    Pjotr van van Schothorst

    Thanks, Götz, for your quick advice.

    I started all over again with a 1M triangle model instead of the 100k model I used initially.

    Now, every time after cutting out a tree, I ran a Clean Model operation. That worked better, although the closed holes now don't show a nice texture. Ideally, the covered hole should show the orthogonal top view of the area.

    On top of that, a UV error was introduced somewhere along the simplification or smoothing process.

    Here the correct texture:

    Here the Unwrap of the incorrect texturing:

    Is there any way to get the correct texture back again? I spent many hours to clean up the model, getting rid of the trees and filling the holes, I'm not looking forward to do that again...

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Pjotr,

    can you describe your workflow step by step? It could be several issues here.

    The blurry faces are probably caused by too large triangles - there's a setting for that: Large Triangel Removal Threshold. But I'm afraid that if you change the geometry of a model too much, the texture will not look like you want it to. You'd probably need to use an external tool and paint textures from individual images onto your desired surface...

    0
    Comment actions Permalink
  • Avatar
    Jasper Mink

    Hi Pjort,


    I agree with Götz here in that you could try increasing the value for the "Large triangle removal treshold" from the default value of 10 to some high number like 100 or 200 or even higher. You can check which value you need to use by using the "Advanced selection tool" and changing the value of the "Edge Threshold multiplier".

    If you change this parameter from the default value to for instance 50 and press "Select large triangle", RC will only select the large triangles. Set this parameter to a number at which RC is unable to select any triangle for that size. Then use that size for the unwrap tool and fill it in in the "Large triangle removal treshold".

    After unwrap has finished, use Sweet mode to check if your large triangles (i.e. removed vegetation areas) now also show up as checkered boxes.

    0
    Comment actions Permalink
  • Avatar
    Pjotr van van Schothorst

    Thanks a lot guys, that fixed it! Large triangle removal treshold is now set to 170. Unwrap looked OK, re-texturing also:

    Now I have much better texturing on the filled holes as well. Great!

    0
    Comment actions Permalink
  • Avatar
    Pjotr van van Schothorst

    Here a video animation made with Lumion of the scene, after cleaning out the trees, filtering and smoothing the terrain, and replacing the main building with a new design (which was the objective of this architecture visualization).

    0
    Comment actions Permalink
  • Avatar
    Lucia CR

    very nice!

    0
    Comment actions Permalink

Please sign in to leave a comment.