Texture has spotty artifacts

Answered

Comments

5 comments

  • Avatar
    Zuzana Ďuríčková CR

    Hello,

    can you please describe your steps when creating texture? Did you unwrap your model first in RealityCapture? What settings did you use?

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Irad Eyal,

    could it be related to this issue: https://support.capturingreality.com/hc/en-us/community/posts/360011270552-Sweet-view-texture-resolution-inconsistency ?

    Weirdly, this post cannot be found via search and I had to use my notification emails to access it again...

    0
    Comment actions Permalink
  • Avatar
    Irad Eyal

    Thanks for responses! I unwrapped in Reality Capture (not sure if I did it as a separate step, or as part of the texturing following a simplify from a really big ~360m poly model to a 32M Poly then to a 5M poly model. 

    I redid the texturing in the VISIBILITY mode instead of the PHOTOCONSISTENCY mode and the results were better. Here's a sample:

     

    0
    Comment actions Permalink
  • Avatar
    Irad Eyal

    Zuzana,

    It's interesting, when I try to find the texture settings for the original, spotty model at the top of this post, RC doesn't list the settings I used. It says "unknown". It also says texture utilization 0%. There is a little "tx" next to the model indicating it was textured, and I can render out views that appear textured, but the info window is strange.

    Is that a clue? Here are the settings for that spotty model:

    0
    Comment actions Permalink
  • Avatar
    Götz Echtenacher

    Hi Irad,

    that might indeed be a clue. It could be that the model isn't textured but only hat vertex colours.

    Would be interesting to know if that's the result of a bug or caused by user intervention. 

    You test the texturing if you create an orthophoto or a rendering of the model.

    0
    Comment actions Permalink

Please sign in to leave a comment.