Simplified model looks bad (weird lines,...)

Comments

5 comments

  • Avatar
    Ondrej Trhan CR

    Hi Simutech21,

    what were your Simplify settings? Did you simplified in one step or in more steps (it is recommended to simplify not more than 50%). 

    0
    Comment actions Permalink
  • Avatar
    Simutech21

    Thanks for your reply! It was set to 600k triangles/300k vertices (so 3%) and I didn't change any of the other settings ("Absolute" type, reprojections disabled, part merging enabled). Afterwards I didn't even bother unwrapping/re-texturing, so I don't know if that would have made a difference. I just noticed that the high quality model is split into 11 parts (must have happened automatically during reconstruction) and where these meet is exactly where I noticed a couple of the weird lines.

    I also generated the "Normal Detail" model but that still has 4.2mio triangles (2 parts). If I simplify that to e.g. 200k triangles (around 4%), the resulting model looks fine, no line or anything like that where the "parent's" two parts meet.

    What is the recommended way of simplifying to less than 50%?

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    I wrote it in wrong way. You should do incremental steps during simplification by 50%.

    For example: 9M -> 4.5M -> 2.25M until you get the model with wanted number of triangles.

     

     

    0
    Comment actions Permalink
  • Avatar
    Simutech21

    Oh, I see. What's the reason behind this? Will it not give you an exact model (as exact as you can be with the lower triangles count) if you simplify by too much in a single step? Do you have to unwrap/texture every simplified model along the way too? Is there a way to automate this?

    Sorry for all the questions!

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    There can be some model corruptions caused by too high simplification, the model parts won't be preserved well. It is also because, that a lot of triangles are replaced by one and the detail is lost.

    You can texture just last model, also you can use texture reprojection.

    You can automate the process using CLI commands.

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.