Unwanted Texture Padding/Gutter on Texture Reprojection

Comments

13 comments

  • Avatar
    Ondrej Trhan CR

    Hi Quantum Theory,

    what were your texturing and reprojection settings? Is this happening also near some other holes?

     

    0
    Comment actions Permalink
  • Avatar
    Quantum Theory

    There isn't much to enter, to be honest. The texture reprojection settings are just set to automatic for sampling and projection distance, then I choose to render color, normal, and height.

    Wherever there is a hole, RC will add a gutter and padding in the texture of some distance. If the holes are small enough, they are completely covered by the gutter and so alpha is white where those pixels reside. I would have expected them to be black.

    Imagine I was rendering a leaf, deleted all the large polygons from the high poly, then rendered to a flat plane in RC. The alpha channel RC generates of that leaf would include pixels from the gutter which shouldn't happen. 

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Did you create this hole somehow in RealityCapture? RealityCapture is creating a watertight model, so there shouldn't be holes in the model. On the image it seems, that it is the edge of the rock. As there is no real texture from images, therefore it is creating something like blurry texture over these areas.

    0
    Comment actions Permalink
  • Avatar
    Quantum Theory

    Yes I completely understand that.

    When you scan a surface, reality capture fills in geometry in the areas where the cameras didn't see.. It creates large triangles in those areas to make the model water tight.

    I remove those triangles since it's bad data anyway, and so I naturally assume those empty areas of the model will be transparent in the alpha channel of the textures when projected.

    However, when the texture gets reprojected, RC then adds more gutter in those empty areas. I can't seem to control how much and was hoping you guys could give me some help there.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi,

    which parameters did you used as Gutter for high poly model? How much textures did you have and what were their resolution? How is it on your simplified model?

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Also, what were your texture settings (not just texture reprojection settings)?

    0
    Comment actions Permalink
  • Avatar
    Quantum Theory

    Color and Texture Settings are always: (gutter can't be <1)


    Reprojection:



    The simplified model is just a flat plane with UVs mapped from 0 to 1. That is set to create only 1 texture at 8192x8192. 


    0
    Comment actions Permalink
  • Avatar
    Quantum Theory

    Any news on this bug?

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi,

    you can try this texture settings, which should give better texture results:

    Also, are those gutters visible in the application or it is in external software?

    0
    Comment actions Permalink
  • Avatar
    Quantum Theory

    Those settings increase the gutter size. I'm trying to remove the gutter.

    I'll just file a bug. Thank you.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi, I am trying reproduce this, but I am not able to do it.

    How does look a model on those parts without texture in solid and vertices mode?

    What version of RC are you using?

    Is it possible to share your data?

    0
    Comment actions Permalink
  • Avatar
    Demonfall

    Hi, I completely agree with Quantum Theory here. I'm having similar issues. Is there not a way to have a gutter toggle when baking? Thanks!

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi Demonfall, can you contact our support with your problem? Thanks.

    0
    Comment actions Permalink

Please sign in to leave a comment.