Import Agisoft Camera Alignment

Comments

15 comments

  • Avatar
    Ondrej Trhan CR

    Hi GarethOReilly,

    there is a way, you need to export bundler.out file from that software and use it in RealityCapture.

    Bundle-Out has become a standard in academia. RealityCapture allows direct loading of bundle-out projects.

    How to open a bundle-out project:

    • Click on the application logo in the top-left corner to open the file menu.
    • Select Open (ctrl+O).
    • Change the file extension type to Bundle-out project.
    • Select your .out file and confirm the selection by clicking the Open button or using the (ctrl+O) shortcut.

    After opening a bundle-out project, you do not need to run alignment again. You can continue and directly calculate a 3D model.

    Bundle-Out import restrictions:

    • Images are named as number.jpg, e.g., 55.jpg or 00055.jpg. In the latter, the file name is always at most 5 letters long. Only the jpeg file format is supported. Image numbering starts with 0 or 1 and, depending on the N-1 or N ending, where N is the number of images.
    • Images are assumed to be undistorted.
    • Distortion model is ignored.
    1
    Comment actions Permalink
  • Avatar
    GarethOReilly

    Thank you very much for your help. It is greatly appreciated.

    0
    Comment actions Permalink
  • Avatar
    JasonWyatt13

    Hi Ondrej Trhan,

    I tried using the method you showed above but when I open the bundle.out file in RC it gives a "File not found" error message. Is there a way around this?

    Thanks.

    0
    Comment actions Permalink
  • Avatar
    Jakub Vanko CR

    Hello Jason,

    follow the rules Ondrej sent you and make sure your undistorted images from MS are together with the image list and Bundler (.out) file in the same folder as in the screenshot. It will work, I just tested it.

    0
    Comment actions Permalink
  • Avatar
    JasonWyatt13

    Hi Jakub,

    Thank you very much, I was importing the bundle.out file and the associated .txt into my project that already contained my images. I'll try to import them all together. Thanks again.

    0
    Comment actions Permalink
  • Avatar
    bassistas

    Does anyone know why my model is rotated 90 degrees when I import a bundler.out from agisoft? All photos are taken from a drone. In metashape the orientation is correct.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi bassistas, did you follow all mentioned rules from above?

    Is your project georeferenced? Do you have set right coordinate system?

    0
    Comment actions Permalink
  • Avatar
    bassistas

    Yes, I import the bundler.out and all images successfully according to the mentioned rules above, just the model comes out rotated 90 degrees. All photos are from a drone so they have GPS coordinates, I have set up everything correctly already in metashape. In metashape I also had some laser scans in the project which I used them as a reference to align all the drone photos but as metashape exports them as tiff files  realitycapture couldn't load them along with the jpegs so I removed these from metashape and then I exported the bundler.out with the photos.  Do I need to change any settings also in realitycapture after the import? 

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi, is it possible, that it was rotated in Metashape? I tested it and after alignment, when I click number 7, what is a Top view, I can see the model from the side. It seems similar to your case, as the Z axis should point up, not to the side.

     

    Also, did you export in local coordinate system?

     

    0
    Comment actions Permalink
  • Avatar
    bassistas

    Hello, no, in metashape when I click number 7 I see the top view of the model. So it's correct in metashape and I export in local coordinate system.

    When I open the bundle out in realitycapture the front view is the top. Is there a way at least to rotate the model precisely at 90 degrees? I tried the define ground plane tool but this let me rotate the model by mouse only, there is no keyboard input.

    Also if I try to start the model creation in normal detail or in preview I always get an error: "operation failed" after a few seconds. So no way to create the model even rotated at 90 degrees.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi, you can rotate the alignment according to recontruction region.

    Go to Scene 3D tab/Tolls/Mesh model/Info panel (you need to have reconstruction region to activate this tool)

    Then rotate the region to a wanted angle and then select Set Ground by Reconstruction Region

    About operation failed, is there something else written?

    Do you get operation failed also when you don't rotate the alignment? Can you try clean install (open RealityCapture with pushed SHIFT and there choose Make it like a clean install)?

    0
    Comment actions Permalink
  • Avatar
    bassistas

    ok I managed to rotate the model per your instructions but now I'm stuck with the "operation failed" error when I start the creation of the model. I tried also the clean install with shift and still does the same. It does this even if I don't rotate the alignment. Is there any log file saved somewhere to look for further info regarding this error?

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Do you have this error also on some another dataset? Where are your data saved? Which GPU do you have? Are you using this account in the application? Is the operation failed only info or is there also something else written?

    Please make sure you do not have any non-latin characters in the paths to your project and images. Please try to clear the cache manually as described here and then again clean install.

    0
    Comment actions Permalink
  • Avatar
    bassistas

    ok finally after a lot of tries I found what was causing this error, I had the temp folder path on an SSD which has a second installation of windows inside and there was a write permission issue. When I changed the temp path to another disk it started working perfectly!

    Now the only unresolved issue I have is how can I import along with the other photos the aligned .tif  laser scans files from metashape as bundle out. 

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    It is not possible, you need to import laser scans in E57 or PTX format and RealityCapture is creating its own format (LSP) from these laser scans.

    0
    Comment actions Permalink

Please sign in to leave a comment.