Fbx in UE5 looks bad

Comments

5 comments

  • Avatar
    ecko360RC

    Try exporting as LODs and use that. There are guides on youtube on how to have high poly meshes that have LOD using FBX. Personally, I haven't done it yet but I have been considering it since I have been dealing with larger and larger meshes as of late.

    0
    Comment actions Permalink
  • Avatar
    CristianThomassi

    It already look bad at lod 0. Why would I export more LODs.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi CristianThomassi, here is our simplified workflow that will not produce any texture artifacts assuming you have a precise alignment (which can be an issue from what I can see in the screenshots).

    (Optional)Postprocess your images in your favorite SW like (Lightroom, Capture One, etc) and do not use any lens profiles (we need images with lens distortion on - distorted images)

    Import these inputs RealityCapture

    Scale the scene with the distance constraint tool or Import GCPs, FlightLogs

    Align images and troubleshoot alignment until it gives it most accurate results (with the Ray of Sight and Inspection tool)

    Create a reconstruction region

    Use normal/ high detail reconstruction (create a mesh)

    Filter out large triangles, unimportant parts with the mesh selections and filtering selection tool

    Use the smoothing tool to smooth out the noisy parts if there are any (using mesh selections)

    Use the Clean model tool to automatically repair any topology defects

    Optionally: Use the lasso selection to only simplify parts that require it, do not simplify the whole model, otherwise, you can lose a lot of detail (this step depends on the type of dataset)

    Optionally: Use the simplification tool in 50% increments to get to a suitable triangle count without losing any detail and name the model as a high-poly model. After each step, verify if you are not losing detail or sharp edges. 

    NOTE: don´t forget to save the project after a large calculation to not lose any work

    Create a UV unwrap with fixed texel size setting by selecting the high-poly model (cleaned one) and creating the UV unwrap texture (optionally, you can fill in the unwrap textures with the checkerboard to verify the UV unwrap layout in 2D and 3DS  and search for any UV related issues)

    Then Simplify the model to create a low-poly version (without reprojecting textures setting enabled because this would reproject texture for every low-poly iteration). When satisfied with the low-poly model quality.
    Process of simplification:
    Use the lasso selection to only simplify parts that require it, do not simplify the whole model, otherwise, you can lose a lot of detail (this step depends on the type of dataset)
    Use the simplification tool in 50% increments to get to a suitable triangle count without losing any detail and name the model as a high-poly model. After each step, verify if you are not losing detail or sharp edges. 

    Filter out large triangles, unimportant parts with the mesh selections and filtering selection tool

    Use the smoothing tool to smooth out the noisy parts if there are any (using mesh selections)

    Use the Clean model tool to automatically repair any topology defects

    NOTE: don´t forget to save the project after a large calculation to not lose any work

    Create a UV unwrap with fixed texel size setting by selecting the low-poly model and creating the UV unwrap texture (optionally, you can fill in the unwrap textures with the checkerboard to verify the UV unwrap layout and search for any UV issues)

    Then click on the Texture reprojection tool in the Reconstruction tab and select high poly as a source model and low-poly as a target model. Enable normal map generation and click on reproject (change the reprojection distance or sampling if you will see any issues)

    Then just export the model with these settings:

    Note: Also, by selecting Unreal Engine transformation preset model will be automatically scaled and rotated to be correctly displayed in Unreal Engine

    After importing the model to Unreal Engine don´t forget to check two of these settings to read the 16-bit normal texture map correctly in Unreal Engine.
    Also don´t forget to check all the texture materials if diffuse maps and normal maps are correctly connected to the master material (and optionally you can tweak roughness, specular, and AO channels too by creating a more complex material)


    This should give a good understanding of how it works and hope this was helpful to you!

    0
    Comment actions Permalink
  • Avatar
    CristianThomassi

    Ok. Thank you very much for the reply. I'll give it a try.

    0
    Comment actions Permalink
  • Avatar
    YYTSSLN

    it really work,thank you so much,by the way ,I found a other way that we can import scan model it to max 2018,then use datasmith plugin to export to UE4 or UE5,it works too.

    0
    Comment actions Permalink

Please sign in to leave a comment.