GLB Export (textures misaligned)

Comments

6 comments

  • Avatar
    Ondrej Trhan CR

    Hi EricHupe,

    what type of project is this? What were your texture settings? What were your export settings? Which RC version did you use?

    0
    Comment actions Permalink
  • Avatar
    EricHupe

    This is an interior room scan. I reprojected the textures and normals from the higher poly model. This is a 400k poly model with 8 texture maps. Any time I export the model with 1 texture map, the GLB export works great. However, when I export a model with more than 1 texture map, I get this mess. Here are my export settings. Thanks for the help!

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Thank you for your settings.

    I will try find out, if this is a bug (it seems so for now).

    I tested it and when you use these export settings (Export to a single texture file set to No in a model with more textures), you should get a model with a nice texture:

    0
    Comment actions Permalink
  • Avatar
    EricHupe

    Thank you Ondrej Trhan CR. I will give this a try and see if it helps. More soon! -Eric

    0
    Comment actions Permalink
  • Avatar
    EricHupe

    Hi Ondrej Trhan CR. Your suggestion worked but it inflates the file to a size that is not usable. Perhaps I am making a mistake earlier in my workflow. My goal is to have a low-poly model with the best possible textures for web viewing as a GLB. I've been reprojecting the normals from the higher model, but to get the best possible textures I need more than one texture map.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi Eric, when you were reprojectiong the texture, did you follow these tips: https://www.youtube.com/watch?v=6fQjL0EQIfs?

    Also, as I wrote before, this seems like a GLB bug. I will file it as a bug into our database.

    0
    Comment actions Permalink

Please sign in to leave a comment.