Allow installation of previous versions alongside latest version — new versions constantly broken

Comments

24 comments

  • Avatar
    BenjvC

    I'll admit, this feature to allow running a previous (stable) version seems critical at this point.

    0
    Comment actions Permalink
  • Avatar
    shveddy

    Yea, I mean the very nature of this software is that for a certain subset of users it is handling huge amounts of incredibly varied data over very long amounts of time, so it must be impossible to find edge-case bugs for those users before releasing an upgrade to the general public. It’s pretty easy to test against simple datasets, but the power users are going to throw some crazy challenges at the software that will reveal bugs that may require days or even weeks of reconstruction time to even find, let alone fix.

    This is all fine, just part of the process, but also I can’t just wait around wasting days and weeks of my year, trouble shooting issues, and waiting for fixes, when I’m on a deadline and I know that previous versions just worked.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    You can download installation file for a wanted release here: https://support.capturingreality.com/hc/en-us/sections/115001056925-New-Releases

    To uninstall you current version, you need to have its installation file and open that file.

    0
    Comment actions Permalink
  • Avatar
    BenjvC

    Thank you, Odrej. Most useful.

     

    Benjy

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    Hi,

    is there any progress on that front? Being able to download older installers is fine and all, but we're not able to run them because we're forced into updating the older version to the current one. 1.2.0 broke our workflow and it would be nice to be able to just use 1.1 Blaze again. 

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi S_SC_, there weren't any changes there.

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    No changes between the versions or no changes regarding being able to use an older version?

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    The version has the validity for one year. After this time it is not possible to use it and the newer version has to be installed. 

    What problem do you have with newer version? 

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    Since 1.2.0 our alignments via XMP files doesn't work well anymore and the textures are off all the time. We did not have that issue in Blaze.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    I am not aware about changes of XMPs. Aren't these used in alignment? In what kind of workflow are you using them?

    Can you show me, what do you mean by textures are off? What are you texture settings?

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    Would there be an easier way of showing this, like a Teams Call or something like that?

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    You can contact our support with this issue, but we don't do calls, just email communication. 

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    I'll reconstruct and texture something "quickly", just to demonstrate the issue. Our texturing settings are the default settings, same as in 1.1 Blaze. We played around with them a bit, but did not yield any better results.

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    https://imgur.com/a/XZV1a3s

    this shows the textured reconstruction vs the ground truth on the bottom.

    it's a bit of a constructed example, because we usually use 24MP source images instead of 12MP like here, but it's demonstrating the issue we have with our textures (and that's probably a result of the alignment/reconstruction) since 1.2.0. In Blaze the results from that same setup looked crisp. The camera positions are exported via XMP as locked.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    This is quite unusual, it seem like badly aligned cameras.

    Can you describe your workflow there? Are you using some CLI script? 

     

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    we are creating sort of a calibration with a calibration object, export the XMPs and then use these for all subsequent captures. that worked very well until 1.2.0 came out. we've now tried for weeks to find the issue with the capturing, camera positions etc pp, but the only difference to when it last worked, is the software version of RC. 

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    the plan is to run it through a cli script, but the tests have been done manually

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    The object during capturing is placed over rotation table? Are you using one camera or more?

    For this calibration, are you using CPs or just distances? Is it possible to share these images with us also with XMPs?

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    we use 3 cameras, it's a turntable, yes. for calibration we use a couple of CPs and some ground control points to fix the coordinate system, and then we export the XMPs and the reconstruction region from the calibration project. the reconstructed calibration looks prestine and the textures are very good there, so the alignment in the calibration project is great.

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    it was recommended to export the XMPs as fixed positions, so that's what we did and that worked fine before. now the alignment seems to be just a little bit off between the images, even when the intervals between captures are precise (which they are not always), but Blaze managed to compensate for slight mistimings in the capturing process and still created good looking results. we just assume by now, that something changed internally in how the XMP calibration is being treated or whatever, we just cannot put a finger on it and how to solve it.

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    as for sharing images and XMPs we would prefer some other communications channel, I don't think this is the right place for that ;)

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Yes, sure, can you send me the link to the data on trhond@capturingreality.com address?

     

    0
    Comment actions Permalink
  • Avatar
    S_SC_

    Alright, I'll prepare a data set later on and send you a link, this might be on the weekend though since I have to leave soon.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Thank you, will wait for your data.

    0
    Comment actions Permalink

Please sign in to leave a comment.