Crashing on Aligning (Draft)

Comments

13 comments

  • Avatar
    Ondrej Trhan CR

    Hi Phill,

    for alignment is used just RAM, not GPU. But according to its size it could be enough for alignment. Do you have this error also using ordinary alignment? What is written in the console view before the crash?

    Where is your cache folder saved? Do you have enough free space on that disc? What kind of discs are you using?

    With new install, do you mean clean install as is described here: https://support.capturingreality.com/hc/en-us/articles/360012151919-RealityCapture-settings#:~:text=RealityCapture%20Reset&text=NOTE%3A%20If%20you%20choose%20option,RealityCapture%20from%20the%20Windows%20registry. (section RealityCapture Reset)

    What kind of images are you trying to align?

    Crashlogs are readable just for our developers. 

    0
    Comment actions Permalink
  • Avatar
    Sk8fly

    Hy Ondrej,

    thx for your fast reply.

    • Yes also when i use the ordinary alignment.
    • Cache is "system temp" on C: which has 160GB free its an ssd
    • the new install where taken further, i have done this by uninstall complete, then wipe the registry and folders left (revo uninstaller)
    • Images are jpg's from an building (streetlevel) 811 in total but it also happens when i only take 200 of them. images were shot by sony alpha 6000 with an 10-18mm sony objective so there are also the correct exif data in the imageset. (i can send it to you i f you want to test).
    • If chrashlogs would give us a hint were the problem might be it would be easier to try other solutions on our own

    thanks for your help

    phil

     

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi Phil, did you try also mentioned clean install (it is different to new install)?
    Did you check the console view during alignment?
    10-18 mm focal length is quite short, you should get better results with over 20 mm. It would be nice if you will be able to send those images to check. Are your images also geotagged? 

     

    0
    Comment actions Permalink
  • Avatar
    Sk8fly

    Hy Ondrej,

    i thought that a complete install should be maximum or? i did'nt get the point what should be different. but i will try.

    yes console showing:

    feature detection completed. 

    processing 4% completed time remaining 1861 seconds

    sry i didn't mention; the a6000 has a cropfactor with 1,5 so a fullframe equivalent is 15-27mm. i know its short but i have got okay results before. but thanks for the suggestion. how can i send you those images? posting a dropboxlink here for you? 

    no sadly my images are not geotagged. are you aware of some solutions for mirrorless cameras because it would be quite handy for alignement or?

    thx

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi, there is difference between new install and clean install. It could help if there are some wrong settings. 
    The dropbox link will be fine.
    The principles are the same basically for all cameras.

    0
    Comment actions Permalink
  • Avatar
    Sk8fly

    hy Ondrej,

    here is the link. this set contains only the street level photos which i later would like to merge with drone shots.

    the drone shots are working fine but these are not...

    btw a clean install give me the same problem

    https://www.dropbox.com/s/8iz0hhg1l3nkdxe/Fotos%2020220816.zip?dl=0

    thx greets phil

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi, the attached link is not working for me. 

    0
    Comment actions Permalink
  • Avatar
    Sk8fly

    Hy, i updated the link. sry

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    I don't know why, but still doesn't work:

    0
    Comment actions Permalink
  • Avatar
    Sk8fly

    Ok sry, saw that the rights were not set correctly. now it will work

     

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Hi Phill,

    I was able to align your data without any issues (there is more components after alignment, but it is easily solvable).

    Are you using control points in your project?
    It might also help to align the images in several batches and keep adding images in smaller increments. If the resulting alignment from the smaller batch looks OK I would recommend to select all the images in this component and change Lock pose for continue to True. This will fix the relative positions among cameras in this component and during the next run connect more images to this existing one.
    During alignment are used these processes: CPU, RAM, Storage, are you able to see all of them during alignment in the Task Manager?

    Would you try to manually set windows swap to 150% of your current RAM so you would have 64GB+ 150% on windows swap (keep in mind to use an SSD disk for that when you will all the time have at least 90GB of storage left)
    How To Manage Virtual Memory (Pagefile) In Windows 10 | Tom's Hardware
    The minimum and maximum size of the Pagefile can be up to 1.5 times and 4 times of the physical memory that your computer has, respectively. For example, if your computer has 1GB of RAM, the minimum Pagefile size can be 1.5GB, and the maximum size of the file can be 4GB.
    By default, Windows 10 automatically manages the Pagefile according to your computer’s configuration and the RAM present in it. However, if you ever face lagging while working on Windows 10, or you start getting the PAGE_FAULT_IN_NONPAGED_AREA or KERNEL_DATA_INPAGE_ERROR Blue Screen of Death (BSOD), managing the size of the Pagefile manually is the first thing you should look for.

    0
    Comment actions Permalink
  • Avatar
    Sk8fly

    Hy Ondrej,

    thanks for your reply.

    i have done the increase of the virtual memory = same behavior :-/ But this is definitely a good idea because it was set to 9GB from win10

    Cpu is 100%

    ram is at 20% (from physical) Edit: i did a mem-test for 12 hours, no problem with ram.

    ssd is at 1-10%

    when i click "draft" it stops under a minute. when i click align images it stops after 2 mins....

    what can i do next? i'm also open for a screensharing/recording if that would help.

    thx phil

    0
    Comment actions Permalink
  • Avatar
    Wallace Wainhouse CR

    Hi Phill,

    Sometimes issues like this can be caused by a PSU being too low powered for the PC build. I cannot say for certain this is the cause, but it's certainly worth taking a look. 

    0
    Comment actions Permalink

Please sign in to leave a comment.