New workstation is faster but less accurate in RC for some reason.

Comments

4 comments

  • Avatar
    SimulaChroma

    Interesting, I just noticed my Preselector settings were different.  Let's see if that does the trick :)

    Ok yeah that was it! After setting Preselector Features value to 40,000 I was able to get the same results on both machines but in about half the time on my new machine.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    First, here you can read more about our minimal HW requirements.

    Generally, most of the processes in RealityCapture are out-of-core apart (not dependent on the RAM) from the Alignment process (registration of cameras).

    RealityCapture will use all available RAM if it leads to faster computation. Otherwise, it splits jobs so that it fills into the Windows System memory (SWAP). So technically 16GB is enough for reconstruction, texturing, etc - but more RAM could lead to faster processing.

    Memory consumption during the alignment phase depends on the number of images (not size) and the number of detected features per image. For the default setting of 40 000 features per image (Alignment setting), you can expect the following boundaries:

    - 2,000 images - 16GB RAM

    - 4,000 images - 32GB RAM

    - 8,000 images - 64GB RAM

    - 16,000 images - 128GB RAM

    By decreasing the number of detected features to half you can approximately decrease the memory consumption by half as well. The approximate formula is: RAM = features x images x 200 bytes. 

    Also, it is not necessary to have set 120 000 image features. It is quite a lot. The recommended maximal value is 60 - 80 000. 

    0
    Comment actions Permalink
  • Avatar
    SimulaChroma

    Awesome! thanks again for some great info.
    The reason I got a new machine was to upgrade to from 32 to 64 RAM because my 32GB laptop would fail on texturing in RC after working very well with all the other workflow stages. This was always on any unwrap of higher fidelity than 2x 8k maps so I assumed this just required a machine with more RAM.

    The odd thing is that my new machine still only currently has 32GB RAM as I wait for the other to arrive but it is completing the texturing successfully.
    Next I'll try Fixed Texel/ Optimal and see if that withstands texturing on my workstation.

    Any idea why my laptop 32GB DDR4 @2666 Mhz fails
    but my workstation 32GB DDR4 @3200 Mhz is successful?

    Maybe due to some Swap file issues.  Do you have ideal settings for Swap?

    If possible would like to continue using my laptop alongside my workstation for RC if the specs are fine but I had this texture failure on 5 different assets I'm currently working on and thought it just wasn't going to work for the fidelity I'm trying to achieve.

    0
    Comment actions Permalink
  • Avatar
    Ondrej Trhan CR

    Regarding HW there is basically 1 rule of thumb. The clock speed of the processor is more important than the number of cores. So, if you have a 12-core processor with a 5 GHz overclock, you will get better results, than with a processor with 3 ghz and 32-cores. So this could be the difference between laptop and workstation.

    You would try to manually set windows swap to 150% of your current RAM. So for example if you have 128 GB RAM you could have 128GB + 150% on windows swap (keep in mind to use an SSD disk for that when you will all the time have at least 180GB of storage left)

    How To Manage Virtual Memory (Pagefile) In Windows 10 | Tom's Hardware

    The minimum and maximum size of the Pagefile can be up to 1.5 times and 4 times of the physical memory that your computer has, respectively. For example, if your computer has 1GB of RAM, the minimum Pagefile size can be 1.5GB, and the maximum size of the file can be 4GB.

    By default, Windows 10 automatically manages the Pagefile according to your computer’s configuration and the RAM present in it. However, if you ever face lagging while working on Windows 10, or you start getting the PAGE_FAULT_IN_NONPAGED_AREA or KERNEL_DATA_INPAGE_ERROR Blue Screen of Death (BSOD), managing the size of the Pagefile manually is the first thing you should look for.

    0
    Comment actions Permalink

Please sign in to leave a comment.